The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel and Fedora core 6

Discussion in 'General Discussion' started by lndinev, May 30, 2007.

  1. lndinev

    lndinev Registered

    Joined:
    Jan 24, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Please, tell me when Cpanel will work with FC6. Now I have problems and from the support team answer me I need to wait a FC6 to be included as an official supportes OS.
    I need to take decision ASAP do doowngrade my OS to FC5 or to wait few days...Monts.. Years...
    Please, help me to make my decision.:confused:
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Reading the FC6 bugzilla entry:
    http://bugzilla.cpanel.net/show_bug.cgi?id=4746

    It appears FC6 is support in cPanel v11, which means using the CURRENT version of cPanel. There's not much point in using FC5 since OS support for that dies in a few weeks. You might want to consider using CentOSv4 or similar for a more stable environment.
     
  3. h4f

    h4f Well-Known Member

    Joined:
    Jun 5, 2007
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Installing CPanel on Fedora core 6 (today)

    We have waited untill release of Cpanel 11 which supports FC 6.

    So today we have purchased a license, but when running:


    sh cpanel-universal-install.sea

    We got a messed up not working server.

    To our suprise it didn't install Cpanel 11 but 10.x.

    After running:
    /scripts/upcp

    we got:

    Updating /scripts ...
    Sync Source: http://httpupdate.cpanel.net/RELEASE-x86_64/scripts

    <cut>
    PHP version file has been updated to 4.4.6

    We rather like to use 5.2.* (is this possible?)

    <cut>
    This is the pure-ftpd 1.0.21 installer release number 2.tls for platform fedora 6
    pure-ftpd is up to date. Use ftpup --force to force a reinstall


    Why?

    <cut>
    This is the exim 4.63 installer release number 1 for platform fedora 6
    exim is up to date. Use eximup --force to force a reinstall

    why?


    MySQL Setup Script Version 7.0
    Loaded cPPkgs::MySQL ok!
    This is the cPPkgs::MySQL 4.1.21 installer for Linux.
    MySQL 4.1.21 is up to date
    Install Complete

    We need to use Mysql 5.x, is this possible?

    <cut>
    This is the courier-imap 4.0.4 installer release number 4cp for platform
    courier-imap-4.0.4 is up to date
    Install Complete
    Fedora 6 is not supported

    Weird, line before states that Install has completed.


    <cut>
    Three usable mirrors located
    Three usable mirrors located
    Mirror Check passed for cpan.wanadoo.nl (/index.html)
    commit: wrote '/usr/lib/perl5/5.8.8/CPAN/Config.pm'
    CPAN: File::HomeDir loaded ok (v0.65)
    Sorry, we have to rerun the configuration dialog for CPAN.pm due to
    the following indispensable but missing parameters:

    auto_commit


    Normally CPAN.pm keeps config variables in memory and changes need to
    be saved in a separate 'o conf commit' command to make them permanent
    between sessions. If you set the 'auto_commit' option to true, changes
    to a config variable are always automatically committed to disk.

    Always commit changes to config variables to disk? [no]



    Please remember to call 'o conf commit' to make the config permanent!

    CPAN: Storable loaded ok (v2.16)
    Going to read /home/.cpan/Metadata
    Database was generated on Tue, 05 Jun 2007 06:08:36 GMT
    version is up to date (0.7203).

    initfpsuexec: using apache 1.x support
    Fetching http://layer2.cpanel.net/installer/ (0)....@198.66.92.150......connected......receiving...27%...54%...81%...100%......Done
    Requested cPanel Tree: RELEASE
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!cPanel Auto Heal 2.4 Running !!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Processing heal of https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=171178
    Waiting for yum to finish....Loading "installonlyn" plugin
    Setting up Update Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Could not find update match for bind-libs
    No Packages marked for Update/Obsoletion
    Done
    BIND 9.3.4
    Succeeded
    Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE-x86_64/cpanel/version (0)....@69.72.164.152......connected......receiving...100%......Done
    Using mail permissions style: NEW
    Patching /usr/local/cpanel/bin/mysqladmin......Done
    Patching /usr/local/cpanel/bin/hooksadmin......Done
    Wrapper was already updated!
    Versions Match! (10.9.0-RELEASE_10737). You are running the latest RELEASE-x86_64.
    mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)'
    Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists!
    Scanning for new mail senders.....Done
    Scanning suexec_log...Done




    So my question is simple, is it possible to use Cpanel 11 with Mysql 5.x, PHP 5.2.x and Apache 2.x on a Fedora Core 6 (and within some months Core 7).

    If it is possible, how?
     
  4. cpanelinfoseeker

    cpanelinfoseeker Well-Known Member

    Joined:
    Oct 25, 2002
    Messages:
    323
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    NE Illinois
    cPanel Access Level:
    Root Administrator
    Your information shows that you are running the latest RELEASE. Release is still on cPanel 10. It is scheduled to be upgraded to 11 today, but it could change to a different date.

    Here is the latest from cPanel:
    RELEASE
    10.9.0-RELEASE_10737

    You might want to watch "http://layer1.cpanel.net/" and see when Cpanel 11 is available, or if 11 is needed go to edge or current instead of release. Personally, I prefer the Release line...

    Ron
     
  5. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    You can install Cpanel on FC6 and I have gotten it to work on a few
    test servers already but it is not yet officially supported by Cpanel
    and still a little bit premature to be running FC6 if you are planning
    on using Cpanel with Fedora on the server.

    If you are planning on using Fedora on a Cpanel server, I would
    strongly recommend using FC5 instead of the newer FC6 as FC5 is
    directly supported and had had more time to resolve out issues.

    As for Cpanel compatibility ...

    For 32 bit, I'd recommend Fedora Core 5 for those servers

    For 64 bit, I've had the most success with CentOS 64bit v4.x
     
  6. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
     
  7. h4f

    h4f Well-Known Member

    Joined:
    Jun 5, 2007
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    I changed
    /etc/cpupdate.conf :

    CPANEL=release

    to

    CPANEL=current

    then: /scripts/upcp

    service cpanel restart
    Stopping cPanel services: Waiting for cpsrvd to shutdown......Done
    Waiting for cpsrvd-ssl to shutdown......Done
    [ OK ]
    Stopping cPanel dav services: Waiting for cpdavd to shutdown......Done
    Waiting for cpdavd-ssl to shutdown......Done
    [ OK ]
    Stopping cPanel brute force detector services: Name "Cpanel::Hulkd::ERRLOG" used only once: possible typo at /usr/local/cpanel/cphulkd.pl line 86.
    Waiting for cphulkd.pl to shutdown......Done
    Waiting for cPhulkd to shutdown......Done
    [ OK ]
    Stopping pop3 services: Waiting for cppop to shutdown......Done
    Waiting for cppop-ssl to shutdown......Done
    [ OK ]
    Stopping cPanel log services: [ OK ]
    Stopping cPanel Chat services: [ OK ]
    Stopping Melange Chat services: [FAILED]
    Stopping InterChange services: [FAILED]
    Stopping cPanel ssl services: [ OK ]

    Stopping mailman services: Shutting down Mailman's master qrunner
    PID unreadable in: /usr/local/cpanel/3rdparty/mailman/data/master-qrunner.pid
    [Errno 2] No such file or directory: '/usr/local/cpanel/3rdparty/mailman/data/master-qrunner.pid'
    Is qrunner even running?

    Starting eximstats: [ OK ]
    Starting cPanel services: [ OK ]
    Starting cPanel brute force detector services: [ OK ]
    Starting cPanel dav services: [ OK ]
    Starting cPanel Log services: ==> cPanel Log Daemon version 22.2
    ==> Shared RRDTOOL support enabled
    ==> Starting cpbandwd (bandwidth monitoring for IMAP/POP)
    cpbandwd is already running.
    [ OK ]
    Starting pop3 services: Waiting for cppop to shutdown......Done
    Waiting for cppop-ssl to shutdown......Done
    [ OK ]
    Starting cPanel Chat services: Listening on port 2084...
    [ OK ]
    Starting Melange Chat services:
    Starting cPanel ssl services: Using Native SSL support (stunnel not needed)
    [ OK ]
    Starting mailman services: Site list is missing: mailman

    As result nothing is listening on 2084 remotely.
     
Loading...

Share This Page