The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel and Modernbill Dedicated IP

Discussion in 'General Discussion' started by danyb, May 16, 2008.

  1. danyb

    danyb Member
    PartnerNOC

    Joined:
    Jan 22, 2006
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    First of all sorry for my bad english writing its not my first language ...

    We currently have
    Cpanel / WHM : WHM 11.15.0 cPanel 11.18.6-S24255
    ModernBill : Version 4.3.2:B-6:PR:Z:22

    Description of the problem :

    Interface WHM with Modernbill broke since few weeks,maybe in the three last stable update, i think the problem appear with the stamch march update. I know i know im late but i was hoping to see this issue resolve after each newstable version. IN previous versions, when modernbill creates an account through a package with a dedicated IP, it would assign the free IP number. Now it just assigns it to the MAIN IP number
    on the server.

    If you create the package in WHM manually, it uses the available IP number.

    Any idea of what is curretnly hapening ?

    Thanks

    Danyb
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Please open a ticket @ https://tickets.cpanel.net/submit/
     
  3. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    This should be resolved in the next 11.18 builds (not yet published). This shouldn't be a problem in the currently available 11.23 builds.
     
  4. danyb

    danyb Member
    PartnerNOC

    Joined:
    Jan 22, 2006
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hi Ben,

    This is an issue with Cpanel or modernbill ? Because im not the only one with this problem on the Modernbill forum ...

    I have a old version of MB 4.X an another MB user with the lastest 4.X version have the same issue

    MB tech support only want from me to update to the lastest version ... but the issue is present with the lastest version.

    I got an Ticket exchange with Matt Dees :

    Dany,
    This is something I think that you will need to contact ModernBill support for
    as this sounds like an issue with their software and not ours. I can add a
    dedicated IP account just fine via WHM.
    --
    Thank You,
    Matt Dees
    Technical Analyst


    The ticket ID where i got an answer form Matt is 253110 from the manage2 interface.

    I just want to be sure on wich door i have to knock to get this issue resolve.

    Regards,

    Dany
     
  5. JIKOmetrix

    JIKOmetrix Well-Known Member

    Joined:
    Apr 3, 2007
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hi cpanelben,

    I'M using MB 4.41 mod_cpanel 3.1.10 on a cpanel server
    WHM 11.15.0 cPanel 11.18.6-S24255 STABLE tree
    CENTOS Enterprise 4.6 i686 on virtuozzo - WHM X v3.1.0

    and having the same issue. Is the 11.23 build on RELEASE tree or CURRENT tree?

    Thanks,
    Mike
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Have you updated to 11.18.6-R24654 and verified whether the fix we applied worked? If it doesn't, please let me know.


    STABLE doesn't have the fix, at this moment.
     
  7. JIKOmetrix

    JIKOmetrix Well-Known Member

    Joined:
    Apr 3, 2007
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    If I update my cPanel install to release will I get this fix?

    Mike
     
  8. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    We built a new Stable earlier today, so the fix on our side should be present in all publicly available builds.
     
  9. JIKOmetrix

    JIKOmetrix Well-Known Member

    Joined:
    Apr 3, 2007
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    Thanks. I try it and post back.

    Mike
     
  10. JIKOmetrix

    JIKOmetrix Well-Known Member

    Joined:
    Apr 3, 2007
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    I forced an update of cPanel. I'm current in the stable tree. Modern Bill work properly now with dedicated IP addresses in package mode.

    Thank you for addressing this. :)

    sincerely,
    Mike
     
  11. JIKOmetrix

    JIKOmetrix Well-Known Member

    Joined:
    Apr 3, 2007
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    This issue has come back up when using packages with dedicated IP addresses.

    WHM 11.23.2 cPanel 11.23.3-R25533

    Mike
     
  12. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
  13. JIKOmetrix

    JIKOmetrix Well-Known Member

    Joined:
    Apr 3, 2007
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    I'll open that ticket now.

    System info so far:

    WHM 11.23.2 cPanel 11.23.3-R25533
    CENTOS Enterprise 4.6 i686 on virtuozzo - WHM X v3.1.0

    MB Version 4.4.2:B-3:K:001:32

    Mike
     
  14. JIKOmetrix

    JIKOmetrix Well-Known Member

    Joined:
    Apr 3, 2007
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    My Cpanel License is through my host provider for my servers. Do I have to have them open the the ticket?

    Mike
     
  15. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    You can go to http://tickets.cpanel.net and choose the option to submit a ticket without logging in for this particular issue.
     
  16. rsaylor

    rsaylor Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    160
    Likes Received:
    1
    Trophy Points:
    18
    MB 4.3.2 does not work with cpanel 11.23.2

    I get the same connection failure on at least 2 servers now. Trying to update one of them from release to current to see if that makes a difference.
     
  17. JIKOmetrix

    JIKOmetrix Well-Known Member

    Joined:
    Apr 3, 2007
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    If you are getting a connection failure then you may have a firewall issue.

    My Modernbill install started working properly about 2 weeks ago with packages and dedicated IP's set to yes. No chaneg in modernbill just cPanel. I hope this continues.

    Mike
     
  18. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18

    Can you post the specific error message you are getting so we can see what's going on. Thanks
     
  19. rsaylor

    rsaylor Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    160
    Likes Received:
    1
    Trophy Points:
    18
    I'm doing this from my partner's MB, left the password at home. But this was the steps:

    I went in and configured the remote server, for the hostname I tried both the hostname of the server and the IP address. Not at the same time.

    I entered in the remote key, I even tried generating a new one.

    I tried non secure and secure.

    I entered in the server nameservers and IP's in MB.

    I entered in the URL to WHM, http://IP:2086 (I also tried both secure and non-secure)

    For the user I entered in root and root's password.

    I also tried entering a reseller's username that has all access, his password and remote key, same issue.

    For the database at the top I entered localhost. And the cpanel user as root.

    I upgraded WHM to current last night, same issue. I stopped apf, same issue. I do not think it is a firewall issue if stopping apf still didn't work. I also get this same issue on 2 different servers.

    I also went and downloaded fresh MB 4.3.2 and uploaded the mod_cpanel files and the file size was different, same issue.

    The issue is when you go to test the connection, after curl does it test and passes then it tried to get the WHM version and it says WHM NOT OK. It was not able to authenticate.
     
  20. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    Is you've turned this Tweak Setting on in WHM recently, this could be the cause:

    Only permit cpanel/whm/webmail to execute functions that have a referrer that matches one of the domains/ip on this server. This will help prevent XSRF attacks, but may break integration with other systems, login applications, and billing software.

    The specific error message would help track this down as the connection issue could be a bad network connection, key paste missing a character, new lines from a test editor or many other items. I don't see anyone posting on the ModernBill forums about the issue so that leads me to believe it may be server specific.
     
    #20 DaveUsedToWorkHere, Sep 4, 2008
    Last edited: Sep 4, 2008
Loading...

Share This Page