jerrybell

Well-Known Member
Nov 27, 2006
90
0
156
Hello,

I am running Cpanel (11.25.0-R46156 - WHM 11.25.0 - X 3.9) on FreeBSD 8, with perl 5.8.9. Most every perl-dependent port in the ports tree required perl 5.10. I have found a few references to Cpanel not support 5.10 in google from about a year ago, but wanted to see if anything has changed. So, will I have problems if I upgrade to 5.10?

Thanks,

Jerry
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
25
143
Houston, TX
cPanel Access Level
Root Administrator
cPanel will work with Perl 5.10

There were some issues when FreeBSD initially updated to Perl 5.10, related to specific modules. Those have been corrected, and cPanel will work with Perl 5.10 on FreeBSD servers. If you update Perl, be sure to run /scripts/checkperlmodules --full, and please let us know if there are any problems with any modules required by cPanel (which is what checkperlmodules checks).
 

jerrybell

Well-Known Member
Nov 27, 2006
90
0
156
For anyone else looking to do this, I had to rebuild exim after upgrading to 5.10:
/scripts/eximup --force