cPanel and WHM both do not recognize SSL certificate

Operating System & Version
CentOS 7 x64
cPanel & WHM Version
v100.0.9

SidedTech

Registered
Jan 14, 2015
4
0
51
cPanel Access Level
Reseller Owner
Let's Encrypt works fine on the domain itself, but when copied to cpanel, dovecot, etc in WHM, the certificate doesn't take effect.

It says "Manage Service Certs" so I know that's where I apply them, and I can see it's the correct cert that's already installed, but cPanel, and WHM both throw up an error when trying to connect vis https, and if i leave out the (s) it loads, otherwise, nothing. SECURE CONNECTION FAILED.

Any ideas? I'm adding LE to AutoSSL, and then hoping to G*d but we will see!

- Sean
 
Last edited by a moderator:

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
453
217
118
IN
cPanel Access Level
Root Administrator
What exact steps you are taking to add LE SSL?
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
10,961
1,725
363
cPanel Access Level
Root Administrator
We need more details to help on this one.

In general, I would not expect a domain certificate to work on the hostname of the server, as the hostname should be formatted as a fully-qualified domain name, in the format of host.domain.com. You want to make sure the hostname is not the same as a subdomain you are using for web traffic, as that would cause conflicts.

On a cPanel server, the free hostname certificate would get applied automatically, separate from the domain SSL.

If you can let us know why the free certificate isn't working and why you need to manually apply the SSL to the hostname, we can try and provide you with better information on the issue.