cPanel and WHM showing 0 Disk Space

kshazad

Member
Nov 4, 2010
21
0
51
My current server is showing 0 disk space usage for all accounts, even though some accounts are using in excess of 100MB. Does anyone know how I can fix this?

I have tried using /scripts/fixquotas but that didnt work.
When I click on the quota icon next to each account in WHM, I get the error:

"No quotas are enabled on this system."
 
Last edited:

kshazad

Member
Nov 4, 2010
21
0
51
This is the output of the above command:

---------------------

Quotas are now on
Quotas will not be enabled on /backup to prevent performance degradation.
Updating Quota Files......
quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.


quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.

....Done
Reading package Standard
Resetting quota for x1 to 0 M
No filesystems with quota detected.
Resetting quota for x2 to 0 M
No filesystems with quota detected.
Resetting quota for x3 to 0 M
No filesystems with quota detected.
Resetting quota for x4 to 0 M
No filesystems with quota detected.
Resetting quota for x5 to 0 M
No filesystems with quota detected.
Resetting quota for x6 to 0 M
No filesystems with quota detected.
Resetting quota for x6 to 0 M
No filesystems with quota detected.
Resetting quota for x7 to 0 M
No filesystems with quota detected.
Reading package Dedicated IP
Resetting quota for x8 to 0 M
No filesystems with quota detected.

---------------------
 

kshazad

Member
Nov 4, 2010
21
0
51
My cPanel version is: 11.28.83 and I've just forced cPanel to update using /scripts/upcp -force and service cpanel restart

But I still have the same problem, any ideas?
 

kshazad

Member
Nov 4, 2010
21
0
51

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
1
66
hi,

I am also having the same issue. Disk Used is showing 0 MB. I did ran following, all are didn't worked

# /scripts/resetquotas --useplanquotas
# /scripts/resetquotas
# /scripts/initquotas
# /scripts/initquotas --force
# /scripts/fixquotas
# /scripts/fixquotas --force

/scripts/initquotas it gives following output & i did tried in whm same result. disk space usage is still showing 0 MB
Linux Quota Support
Quotas are now on

find below output of /etc/fstab
GNU nano 1.2.4 File: /etc/fstab

none /dev/pts devpts rw 0 0
 

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
1
66
Hi

I also fixed this issue

if the quota shows unlimited in WHM list account run /scripts/initquotas --force or Initial Quota Setup

for disk space usage issue

I have modified fstab last 2 digits 0 0 to 1 1 then
quotacheck -acguvm
quotaon -avug
/scripts/fixquotas then reboot the server & it worked for me :)

giving 5 rates to this thread :)
 

ruzbehraja

Well-Known Member
May 19, 2011
392
11
68
cPanel Access Level
Root Administrator
The problem we had was with all accounts on an additional HDD (/home2)

The disk used would show 0 MB.

When we would run the /scripts/fixquotas, we would get the error:
Quotas will not be enabled on /home2 to prevent performance degradation.

Thanks to this link, it was solved:
Quotas will not be enabled on /home to prevent performance degradation. | cPanel Admins

The solution:
The backup was configured to /home2.
We changed it to /home, and re-ran /scripts/fixquotas.

Everything worked great and disk used is back to normal!

We have reconfigured the backup to /home2