The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel/apf blocking all outgoing mails?

Discussion in 'E-mail Discussions' started by Xavior, Apr 16, 2005.

  1. Xavior

    Xavior Registered

    Joined:
    Feb 17, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I'm using virtuozzo vps and cpanel 10x.
    Whenever i restart the vps, a new rule is added to my iptables.
    and that rule blocks all my outgoing mails.
    Even after i removed that rule, and restarted the server..
    the rule is still there.
    I did save the iptables.. but that does not help.

    anyways, i tried installing apf. and it is working fine.
    but it is still blocking my outgoing mails.
    i tried searching thru the forums but no help is ava.
    the apf config is as follows in this thread: http://forums.cpanel.net/showthread.php?t=30159
    please help!

    thanks
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Are you sure that you haven't enabled WHM > Tweak Security > SMTP Tweak > which is preventing you from doing what you want? That tweak inserts entries directly into iptables.
     
  3. amal

    amal Well-Known Member

    Joined:
    Nov 22, 2003
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    It is a problem with certain kernels which doesn't support match owner option of iptables... You can fix it permanently by recompiling the kernel with the option -

    CONFIG_IP_NF_MATCH_OWNER=y

    in the .config of the kernel..

    Make sure that you add this entry in the .config, after running the make menuconfig, or else, it'll get over written, as certain kernel versions doesn't support this option...

    Temporary fix is to disable smtp tweak...

    Hope, this fixes your issue... :)
     
  4. Xavior

    Xavior Registered

    Joined:
    Feb 17, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Well,
    currently cpanel does not block out any outgoing mails.
    But now, whenever apf is turned on..
    my mails get blocked!!!
    unless i set the devmode to on.
    but this is what i suspect.
    when devmode is on, apf flushes the iptables every 5mins.
    so.. during that flushing... mails get sent.

    so.. what's up with apf that blocks my outgoing mails!!!
     
  5. amal

    amal Well-Known Member

    Joined:
    Nov 22, 2003
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Please try the following procedures......

    1. Move the file - /etc/sysconfig/iptables out of the directory...
    2. Change the devmode to off
    3. Restart apf using the command - /etc/init.d/apf restart

    Try sending a mail.. If you still have a problem, please try the following command from the server, and paste the result...

    telnet smtp.mail.yahoo.com 25
     
Loading...

Share This Page