Operating System & Version
centos 7.9
cPanel & WHM Version
100.0.5

mroxidane

Member
Jan 1, 2022
6
0
1
Patgram
cPanel Access Level
Root Administrator
We have integrated WHM with WHMCS but the auto login is not working, We are getting

An Error Occurred
cPanel API Response: Internal Error (ID 424094926173897)

I checked WHMCS setup is completely fine working for other servers, but this server is having something API issue. Can someone give some hint on what could be casuing this issue? We are using hetzner dedicated server with centOS & Cloudlinux 7.9

I tried updating cPanel, rebooting the server etc, but no luck.
 

mroxidane

Member
Jan 1, 2022
6
0
1
Patgram
cPanel Access Level
Root Administrator
Hello! Is this the auto-login from WHM to WHMCS? Is there anything in the logs when these errors happen?

Thanks for the reply. It's auto-login from WHMCS to WHM. There's no log, we only get the mentioned cPanel API Response: Internal Error.

This is not any problem from the WHMCS end because all other servers we tried is working for the auto login. Only this server has issue.
 

mroxidane

Member
Jan 1, 2022
6
0
1
Patgram
cPanel Access Level
Root Administrator
Since the cPanel API threw the error, have you looked at /usr/local/cpanel/logs/error_log
Yes I checked but couldn't find relevant logs for the API issue. I also tried updating cPanel WHM but no luck. Is this issue casing somehow from hetzner end? I opened a ticket with them but they refused to assist in Software related issues.
 

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
1,045
112
118
Houston, TX
cPanel Access Level
Root Administrator
Hello again.

We can check for a cPanel-side issue if you open a ticket using the link in my signature; or by asking your web hosting provider to open one on your behalf. Provide me the ticket ID if you do. Otherwise, have you considered asking WHMCS support if they have more information as well?

Thanks!
 

mroxidane

Member
Jan 1, 2022
6
0
1
Patgram
cPanel Access Level
Root Administrator
Hello again.

We can check for a cPanel-side issue if you open a ticket using the link in my signature; or by asking your web hosting provider to open one on your behalf. Provide me the ticket ID if you do. Otherwise, have you considered asking WHMCS support if they have more information as well?

Thanks!
No issue from WHMCS. But recently we migrated to hetzner dedicated server from a contabo VPS. I think the problem is with the new server but hetzner refused to help us in software issue.