SOLVED cPanel API Response: You do not have permission to create sessions for the user

3clouds

Member
May 28, 2019
13
2
3
India
cPanel Access Level
Root Administrator
Hello Guys,

As I am a learner. This forum help me a lot to learn new things and settings of cPanel/WHM. I have another issue with cPnael API in WHMCS. I contacted them about the error. But they told me all the settings are okay, and I should contact to cPanel support.

Actually I am migrating user from my reseller account to new server. I setup WHMCS API with root permission. But the new cPanel refuse auto login from admin and from user too.

Below is the error message from WHMCS module log (username is changed due to privacy and security).

{"metadata":{"version":1,"command":"create_user_session","reason":"You do not have permission to create sessions for the user “username”.","result":0}}

Please some one help me!

Thanks
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @3clouds,

1. Can you verify the API token you have configured in your WHMCS configuration exists under WHM >> Manage API Tokens and the "Create User Session" privilege is enabled for this token?

2. Additionally, can you confirm the cPanel user that you are attempting to automatically login with is owned by the WHMCS reseller?

If everything looks to be setup correctly, feel free to open a support ticket so we can take a closer look. You can post the ticket number here and I'll link this thread to it.

Thank you.
 

3clouds

Member
May 28, 2019
13
2
3
India
cPanel Access Level
Root Administrator
Hello Michael,

Thanks for your reply. When I check the owner, it shows my previous reseller username. Only these accounts faild auto login. But other root owner accounts are working very fine!
Now I have to change the ownership to root.

Thank you again!
 
  • Like
Reactions: cPanelMichael