cPanel API servicestatus shows pop service as not running since update to 11.46.1

niceuser

Registered
Dec 16, 2014
3
0
1
cPanel Access Level
Root Administrator
Dear cPanel,

We are monitoring our cPanel servers with a script that checks the status of important services. One of those services is pop. However, since the update to 11.46.1, the result for the pop service says running = 0. When I log in to WHM though, it says the pop service is running just fine.

Also, when I go to the Service Manager in WHM, for the IMAP Server service it says 'Dovecot POP3 Server' and for the POP Server it says 'Courier POP3 Server'. Which services should I check (via the API) if I want to make sure both POP and IMAP are running for our selected mailserver (which is Dovecot)?

Thanks in advance,

Stuart
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

You should see the following in "Service Manager" if you are using Dovecot:

IMAP/POP3 Server
Dovecot IMAP/POP3 Server


What method are you using to verify if POP3 is running?

Thank you.
 

niceuser

Registered
Dec 16, 2014
3
0
1
cPanel Access Level
Root Administrator
Hi Michael,

Thank you for your reply. I am using the API method servicestatus (https://documentation.cpanel.net/display/SDK/WHM+API+1+-+servicestatus). Part of the reply is:

Code:
    class stdClass#30 (6) {
      public $monitored => int(1)
      public $installed => int(1)
      public $name => string(3) "pop"
      public $running => int(0)
      public $display_name => string(11) "POP3 Server"
      public $enabled => int(1)
    }
If I understand correctly, this means the pop server is not running (running = 0). However, if I log into WHM and check Service Status, the pop service does not show any problems. I have attached a screenshot.

service_status.png

Also, as to my other point, when I view the Service Manager, I see the following email related services:

- IMAP Server: Dovecot POP3 Server
- POP3 Server: Courier POP3 Server

Again a screenshot:

service_manager.png

Is it not possible to check both the imap and pop3 services for dovecot separately?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
To update, the analyst on the support ticket advised creating a symbolic link from /scripts/restartsrv_pop to /scripts/restartsrv_imap in order to address this particular issue.

Thank you.