The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel Branding favicon.ico function broken? Doesnt allow uploading of .ico

Discussion in 'User Experience' started by morissette, Oct 27, 2009.

  1. morissette

    morissette Well-Known Member

    Joined:
    May 24, 2009
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Austin, TX
    cPanel Access Level:
    Root Administrator
    domain.com:2083/frontend/x3/resellers/branding/uiedit.html?brandingpkg=packagename

    This is where I am at (obviously not domain.com but you get the idea)

    --Favorite Icon (must be an ico) --> The field that I am trying to upload a .ico to
    --The error --> Inputs not Valid - The image must be either .jpg, .png, or .gif.

    cPanel directly asks for an .ico and then tells me no :(

    I was able to manually change the file /home/invexdes/cpanelbranding/x3/sundaymorning/favicon.png to /home/invexdes/cpanelbranding/x3/sundaymorning/favicon.ivo which works in firefox; however it does not work in IE. (Not that IE is a browser any one should use - but they do)

    Here is cPanel's validation function - as you can see nothing about ico:

    Code:
    <script type="text/javascript">
    
    function register_validators() {
    
            /* generate validators */
                <?cp Branding::brandingeditor(register_validator[['match'\{comma}'jpg_gif_png_jpeg'\{comma}\{leftbracket}document.getElementById[['uifile%']]\
    {rightbracket}\{comma}'$LANG{'ValidatorImageType'}'\{comma} function [[]] {
                          return [[document.getElementById[['uifile%']].value == '' ? false: true]];
                        }]];
                ,number,number) imgtype=ui ?>
    
                realtime_validate_init('mainform');
            }
            YAHOO.util.Event.addListener(window, "load", register_validators, false);
            </script>
    
    So what is the fix for this? - (And yes I attempted to edit their validation script to allow ico - no go)
     
    #1 morissette, Oct 27, 2009
    Last edited by a moderator: Nov 30, 2015
  2. InteractM

    InteractM Well-Known Member

    Joined:
    Apr 2, 2013
    Messages:
    133
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I have exactly this same problem.

    Any clue what is going on?

    Thanks
     
  3. cPanelAdamF

    cPanelAdamF cPanel Product Owner
    Staff Member

    Joined:
    Mar 21, 2013
    Messages:
    174
    Likes Received:
    11
    Trophy Points:
    18
    Location:
    Houston TX
    cPanel Access Level:
    DataCenter Provider
    Twitter:
Loading...

Share This Page