The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel broken when logged in as user

Discussion in 'General Discussion' started by mwknowles92, Apr 11, 2015.

  1. mwknowles92

    mwknowles92 Registered

    Joined:
    Apr 11, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    California
    cPanel Access Level:
    Root Administrator
    The Cpanel page looks like the attached file when logged in as a regular user.
    Clicking on any of the links does not work either.

    If I access the Cpanel using the root account then everything works fine.

    All of the Cpanels for the other users on my server are working correctly, so this issue is isolated to one account.

    I couldn't find anything useful in error logs, but maybe I checked the wrong ones. Any ideas where to look and see what's causing this?
     

    Attached Files:

  2. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Could it be related to file permissions on that user account folder ?
     
  3. mwknowles92

    mwknowles92 Registered

    Joined:
    Apr 11, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    California
    cPanel Access Level:
    Root Administrator
    That's definitely what I'm thinking since it's only this user affected, but quickly comparing permissions to a working user I didn't find anything out of place.

    When viewing the cpanel page, I do see lots of errors like this in the inspector:
    Code:
    http://domain.com:2082/cPanel_magic_revision_1375211624/frontend/x3/branding/tbl-bg-over.jpg 401 (Access Denied)
    Not sure exactly how to fix that though, or even where this magic_revision thing is though.

    I've already forced a cPanel update and added a few things found in another thread to my hosts.allow file but those didn't help.
     
  4. madmanmachines

    madmanmachines Well-Known Member

    Joined:
    Nov 28, 2014
    Messages:
    94
    Likes Received:
    3
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    mwknowles92 likes this.
  5. mwknowles92

    mwknowles92 Registered

    Joined:
    Apr 11, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    California
    cPanel Access Level:
    Root Administrator
    This was the answer. I had to set Cookie Validation to Disabled.
    I didn't even think to check for Cloudflare but sure enough a WHOIS found it.
    Thanks for your help!

    Doesn't look like I can edit the OP to include the solution or mark it as Solved?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,834
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    I am happy to see you were able to resolve the issue. Thank you for updating us with the outcome. There's no need to update the title or original post.
     
Loading...

Share This Page