Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

CPanel changing index of the accounts

Discussion in 'General Discussion' started by JoanaP, Oct 6, 2003.

  1. JoanaP

    JoanaP Member

    Joined:
    Apr 9, 2002
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    301
    The CPANEL changed index of 75% of the accounts, the CPANEL placed index default "There is in the website configured at this address.". How to correct this problem?

    Thank You

    Joana

    cPanel.net Support Ticket Number:
     
  2. elleryjh

    elleryjh Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    166
    Sounds like a problem with your httpd.conf. Resore the most recent working backup of it, and you should be all set.

    cPanel.net Support Ticket Number:
     
  3. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    449
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    All over!
    Yes but this should never have happened. It has happened to us also. What do we need to change in the httpd.conf file to change it back to turn indexing off on ALL sites?

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,505
    Likes Received:
    1
    Trophy Points:
    318
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    If you do a Search (using my Forum name) you will find a post I made on this a few days ago -- the why and how to correct.

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    449
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    All over!
    I did what you said in the other post which I listed below & then restarted http & it still is indexing. Did I do something wrong?

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,505
    Likes Received:
    1
    Trophy Points:
    318
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    449
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    All over!
    That does not seem like the right topic. My problem is when you go to a directory that does not have an html index file in it it shows the directory indexed instead of page can not be found.

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    449
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    All over!
    Anyone have any idea on this?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    1
    Trophy Points:
    168
    Try adding

    Option -Indexes

    to

    /usr/local/apache/conf/access.conf

    and

    /usr/local/apache/conf/httpd.conf

    then restart the web server.

    This will prevent the file list to display when there is no index file in the folder.
     
  10. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    449
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    All over!
    In /usr/local/apache/conf/access.conf this is what I have listed. What should I change it to?

    <Directory />

    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All

    order allow,deny
    allow from all

    </Directory>


    and in /usr/local/apache/conf/httpd.conf I had...

    <Directory />
    Options All -Indexes
    AllowOverride All
    </Directory>


    and I changed it to the below & restarted http but still have the same problem. Will these changes be overwritten on the next cPanel update?

    <Directory />
    Options -Indexes
    AllowOverride All
    </Directory>
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #10 ThunderHostingDotCom, Oct 17, 2003
    Last edited: Oct 17, 2003
  11. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    1
    Trophy Points:
    168
    OK, there was no need to change what you had in httpd.conf:

    Options All -Indexes

    is fine.

    In access.conf, change

    Indexes

    to

    -Indexes
    (meaning, No Indexes)

    and your troubles should terminate for good. :)
     
  12. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    449
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    All over!
    Ok, well that is better but we are getting a 403 error not the page can not be displayed message like before. See below...

    Forbidden
    You don't have permission to access /test/ on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    --------------------------------------------------------------------------------

    Apache/1.3.28 Server at www.ourssl.com Port 80
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. elleryjh

    elleryjh Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    166
    There's nothing wrong.
    That is what is normally shown when indexes are denied.
     
  14. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    449
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    All over!
    But it used to show "Page Cannot be displayed". It's not a big deal.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    449
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    All over!
    Having this problem again. Please let me know if the below looks right before I restart http

    /usr/local/apache/conf/httpd.conf

    <Directory />
    Options All Indexes
    AllowOverride All
    </Directory>

    TO

    <Directory />
    Options All -Indexes
    AllowOverride All
    </Directory>

    ----
    /usr/local/apache/conf/access.conf

    <Directory />
    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All
    order allow,deny
    allow from all
    </Directory>

    TO

    <Directory />
    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All
    order allow,deny
    Options All -Indexes
    allow from all
    </Directory>
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice