CPanel crashes every single day

MattDr2

Well-Known Member
PartnerNOC
Feb 19, 2003
84
0
156
Norman, OK
A side note if anyone tests that ProFTPD RPM, for a configuration that allows users to login to FTP as quickly as with Pure-FTPD, I have these settings at the top of our /etc/proftpd.conf's:

Code:
# This is a basic ProFTPD configuration file (rename it to
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName                      "ProFTPD"
AuthUserFile /etc/proftpd/passwd.vhosts
LogFormat BytesLog "%b"
ServerType                      standalone
DeferWelcome                    off
DefaultServer                   on
DefaultRoot ~ !wheel

UseReverseDNS off
IdentLookups off
TimeoutNoTransfer 900
TimeoutIdle 900

# Port 21 is the standard FTP port.

<IfModule mod_tls.c>
    TLSEngine on
    TLSProtocol TLSv1
    TLSRequired off
    TLSRSACertificateFile /etc/ftpd-rsa.pem
    TLSRSACertificateKeyFile /etc/ftpd-rsa-key.pem
    TLSVerifyClient off
</IfModule>
Port                            21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                           022

# Set the user and group that the server normally runs at.
User                            nobody
Group proftpd

# Normally, we want files to be overwriteable.
<Directory />
  AllowOverwrite                on
</Directory>
Also, be certain that any virtualhost listings below the top lines of code here, are one per IP. If there are more than one virtualhost entry per IP, there will be problems when starting ProFTPD.

Regards,
Matt
 

theshark

Registered
Nov 27, 2003
4
0
151
I am having these exact symptoms, I can ping the server but all services drop off the face of the earth.

I suspect a runaway script but nothing shows in the logs....isn't there anything I can do to stop scripts from doing this?
 

fmalekpour

Well-Known Member
PartnerNOC
Dec 4, 2002
85
1
158
Originally posted by theshark
I am having these exact symptoms, I can ping the server but all services drop off the face of the earth.

I suspect a runaway script but nothing shows in the logs....isn't there anything I can do to stop scripts from doing this?
Add some RAM! Just a tip.
 

fmalekpour

Well-Known Member
PartnerNOC
Dec 4, 2002
85
1
158
so that should be something else, RAM worked for us on 3 servers. Here is some other tips related to this issue:

A. Hardware:
1. RAM amount
2. RAM functionality (there are a lot of damaged ram around, be aware of them).
3. Motherboard I/O Chipset compatibility, Try to disable DMA and Write cache on HDDs. If that was the source of the problem try to change the MB, Disabling DMA and Write cache will reduce system performance and may cause other problems.
4. Heat, Believe it or not motherboard, CPU and HDDs temperature is important. Keep them cool, just like yourself ;)
5. HDD cables, Specially when you use an > ATA100 HDD, Try to change the cable.
6. Backup HDD (if you have), be aware of using low quality HDD for backup. CPanel tries to rsync daily backups with weekly and monthly, This will make a lot of transactions on backup HDD, some times make your system unstable.

B.Software:
1. CPanel S.M.A.R.T Check (in /scripts/upcp), Sometimes system will crash if has a buggy chipset.
2. Use hdparm -i and -I to check hard disks parameters.
3. Check /etc/rc.d/rc.local to see if cpanel adds anything to speed up your hard disks. Sometimes you may get lower performance but stability by removing them.
4. Check the probe status, Take a look at files in /proc/ide, i.e /proc/ide/hda/settings
5 to ... God knows!

Farhad
 

hostit1

Well-Known Member
Jul 24, 2003
88
0
156
I am having this same problem. I have redhat 7.3 and 9.0 systems

The machines that are running RH 9.0, I seem to have problems. I also have 9.0 systems in different datacenters.

Sincerely,

Tim Rice

root 2.91 102.52 2.0
Top Process %CPU 23.0 /usr/bin/perl /usr/bin/mrtg /etc/mrtg/mrtg.cfg
Top Process %CPU 22.0 /usr/bin/perl /usr/bin/mrtg /etc/mrtg/mrtg.cfg
Top Process %CPU 21.0 /usr/bin/perl /usr/bin/mrtg /etc/mrtg/mrtg.cfg
mysql 0.55 48.48 0.0
Top Process %CPU 13.0 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/sls-ce5p21.hostitnow.com.pid --skip-locking
Top Process %CPU 11.0 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/sls-ce5p21.hostitnow.com.pid --skip-locking
Top Process %CPU 9.0 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/sls-ce5p21.hostitnow.com.pid --skip-locking
 

NNNils

Well-Known Member
Sep 17, 2002
580
0
166
Also check size of your root and backup partition when your server crashes daily.
 
Last edited:

fikse

Well-Known Member
May 10, 2003
112
0
166
switching back to proftpd didn't work...

this time I had left a top window open..... the top window stopped responding before the load began to rise....

I logged in via whm and checked the load under service status, it was at 287....

the server was still serving web pages just fine...

I could still log into the server ssh... BUT, I could not run top, sar, ps, or any other performance monitoring command....

the server would not reboot when issueing shutdown -r now... it had to be forcefully rebooted....

this has been happending every coupld of days at random, I can't figure out any kind of pattern...

the filesystem changes mentioned at the beginning of this thread are a year old now..... do they still apply?
 

fikse

Well-Known Member
May 10, 2003
112
0
166
Here is the solution that fixed the problem for us and rpmws:

----------------------
Add the following to /etc/rc.d/rc.local

echo 64000 > /proc/sys/fs/file-max
ulimit -u unlimited
ulimit -S -H -n 4096

Reboot the server

Recompile apache
----------------------

I tried this, but the settings didn't stick... a few hours after the server booted, the defaults were back in place....
 

Dr. Bogger

Well-Known Member
Dec 21, 2003
95
0
156
Has anyone found a fix for this yet?

My server is crashing every day and I can't figure out why.

Please let me know of a fix if possible.

Thanks.
 

chican0

Well-Known Member
Mar 26, 2003
59
0
156
Los Angeles
I paid the folks over at www.justmanaged.com a small price and they secured and optimized my server. Since then, I have had extremely low server loads and not one crash. I have had extemely long uptimes with no problems what so ever...

Well worth the money spent. And it wasn't much to spend. It is a good deal for the services rendered. IMHO.
 

Dr. Bogger

Well-Known Member
Dec 21, 2003
95
0
156
chican0 said:
I paid the folks over at www.justmanaged.com a small price and they secured and optimized my server. Since then, I have had extremely low server loads and not one crash. I have had extemely long uptimes with no problems what so ever...

Well worth the money spent. And it wasn't much to spend. It is a good deal for the services rendered. IMHO.
There website is not even up :(

Anyone know of a actual fix for this?
 

haze

Well-Known Member
Dec 21, 2001
1,548
3
318
I appologise our site isn't up. We have been focused on servicing our current client base and our web site will be up shortly. If you would like to contact me I'd be happy to help.
 

Dr. Bogger

Well-Known Member
Dec 21, 2003
95
0
156
Well I dont have $80 to spend.

Does anyone at all know of a fix for this crashing every day?