Cpanel DNSONLY 11.40 VERSION, or NAT support?

luizhenriq

Registered
Oct 14, 2013
4
0
1
cPanel Access Level
Root Administrator
Hello to all,

I am installing Cpanel DNSONLY in a NAT network on Amazon EC2.

The problem is that installing DNSONLY, it installs the 11:38 that does not support the NAT.

I tried to force the installation, but it always gets in 11:38.

There is DNSONLY 11:40 version with support for NAT? I could not find it.

The structure that I'm creating is similar to this: Part 1: How I Built a cPanel Hosting Environment on Amazon AWS | cPanel Blog

Thank you.
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
cPanel always install RELEASE version, which is currently in 11.38.2.7, after installation you can switch to CURRENT where you get 11.40.0.6.
 

luizhenriq

Registered
Oct 14, 2013
4
0
1
cPanel Access Level
Root Administrator
Thanks for the reply, but in the case of Cpanel DNSONLY where I change to current?

It is through WHM? the option to change the version (Update Preferences) does not exist in dnsonly.

Where do I change?
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
I believe that with this I can get the current.

Update Configuration File

Thank you.
I modified the file /etc/cpupdate.conf, now I am running upcp in my test-dnsonly server, does not seem to finish, stopped in 92%.
=> Log opened from /usr/local/cpanel/scripts/post_sync_cleanup (22653) at Tue Oct 15 14:22:25 2013
[20131015.142225] ==> Starting cPanel....
[20131015.142225] - Processing command `/usr/local/cpanel/etc/init/dnsonlystartup`
[20131015.142226] [25781] Waiting for cphulkd.pl,cPhulkd,cphulkd to shutdown ... not running.
The I just closed it, logged out & in and seems I am running 11.40.0(build 6).
 

owine

Active Member
Jan 10, 2007
44
0
231
Could you verify that you were able to update your build tier on the DNS-Only machine?

Thank you.
I was able to upgrade to the CURRENT tier on a DNSONLY VPS. I installed DNSONLY and then updated the conf file and ran cpup.