The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel DNSOnly, domain DNS errors...

Discussion in 'Bind / DNS / Nameserver Issues' started by privard, Aug 12, 2013.

  1. privard

    privard Member

    Joined:
    Aug 10, 2013
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello to everyone, I'm really hoping I will get someone to help me with this problem or point me in the right direction. I've been scouring the internet and forums for a solution to my problem, but I cannot find anything. So basically, it's my first time setting up a DNS cluster. Really simple diagram:

    boo.domain.com(cPanel)
    | |
    | |__dns1.domain.com(DNSOnly) (For ns1 and ns3.domain.com)
    |
    |______dns2.domain.com(DNSOnly) (For ns2 and ns4.domain.com)

    Here's how the DNS cluster has been configured, on each machine:

    On dns1.domain.com > Connects remotely to boo.domain.com with DNSRole set as "Standalone" > (DNS Path Diagram dns1.domain.com)

    On dns2.domain.com > Connects remotely to boo.domain.com with DNSRole set as "Standalone" > (DNS Path Diagram dns2.domain.com)

    On boo.domain.com > Connects remotely to dns1.domain.com with DNSRole set as "Synchronizing"
    boo.domain.com > Connects remotely to dns2.domain.com with DNSRole set as "Synchronizing" > (DNS Path Diagram is like the one drawn above)

    ns1 and ns2 are currently NS for my old server. ns3 and ns4 are for the new server, to test if everything is working out. The ns3 and ns4 were created at my registrar using dns1.domain.com's IP and dns2.hostingparcel.com's IP. I created entries for ns3 and 4 on domain.com's DNS Zone with the same IPs.

    So, yesterday, when I thought everything was working, I transferred an account to boo.domain.com and created a DNS Zone for that domain. But still today, when I look @ [Removed actual URL] DNS, I get some errors reported from different sites. Some of those errors are:

    -None of the name servers responded in a timely manner
    -Less than Two Name Servers Found
    -Serial numbers do not match (We found no Serial Numbers)
    -No nameservers provided an SOA record for the zone. You should configure your nameservers to have a master slave relationship. The update of the zone information to the slave nameservers should be handled through the SOA record.
    -No MX records exist within the zone. This is legal, but if you want to receive E-mail on this domain, you should have MX record(s). The program can't continue in a case like this, so we are assuming you don't receive mail on this domain.
    -Etc...

    It looks like something is wrong or not syncing or... where should I be looking? I tried so many things... no idea what to look for...

    Thank you a whole lot for anything that could help me solve the problem!
    Phil
     
  2. privard

    privard Member

    Joined:
    Aug 10, 2013
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    As someone just told me;
    "Why not show us a DNS report that might explain more than a heap of text"

    Here's a link to a dns report:
    [Removed actual URL]

    Or check the attached image bellow!

    nukern-dns-report.png
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page