The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel.domain.com, webmail.domain.com

Discussion in 'E-mail Discussions' started by britsenigma, Jan 5, 2012.

  1. britsenigma

    britsenigma Well-Known Member

    Joined:
    Dec 14, 2008
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    I seem to be hitting this problem again:
    /cgi-sys/defaultwebpage.cgi

    On all domains when they try to go to cpanel.domainname.com

    I've read the multitude of solutions on google including upgrading cpanel (this was 2 years ago, so the fixes should be in my current release), caching, dns.

    I've noticed some DNS entries don't have the subdomains in, some do. But it's still not working with the ones that do have it currently, and if I I re-add the entries to those that don't, it still don't work.
     
  2. ruzbehraja

    ruzbehraja Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    383
    Likes Received:
    7
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Can you do a dig:

    Code:
    dig all cpanel.domainname.com
    Code:
    dig all webmail.domainname.com
    What are the entries you are getting? (Make sure you make the IP obscure before posting here Eg: XXX.XX.23.45)

    Is the NS the same as your cpanel server IP or is it through your domain registrar?
     
  3. Jack Plissken

    Jack Plissken Member

    Joined:
    Mar 3, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello, I have this issue. I have two servers
    1st
    WHM 11.30.6 (build 3)
    CENTOS 6.1 x86_64 standard

    2nd
    WHM 11.30.6 (build 3)
    CENTOS 6.2 x86_64 standard

    In 1st server aliases works normal, on 2nd I see "/cgi-sys/defaultwebpage.cgi"
    ============================
    Code:
    # dig all cpanel.domain11.ru
    
    ; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> all cpanel.domain11.ru
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 20999
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;all.                           IN      A
    
    ;; AUTHORITY SECTION:
    .                       33162   IN      SOA     a.root-servers.net. nstld.verisign-grs.com. 2012030201 1800 900 604800 86400
    
    ;; Query time: 21 msec
    ;; SERVER: 8x.2x.44.x#53(8x.2x.44.x)
    ;; WHEN: Sat Mar  3 12:27:18 2012
    ;; MSG SIZE  rcvd: 96
    
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35009
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;cpanel.domain11.ru.           IN      A
    
    ;; ANSWER SECTION:
    cpanel.domain11.ru.    14400   IN      A       8x.2.3x.1x2
    
    ;; AUTHORITY SECTION:
    domain11.ru.           40072   IN      NS      ns2.domain11.ru.
    domain11.ru.           40072   IN      NS      ns1.domain11.ru.
    
    ;; ADDITIONAL SECTION:
    ns1.domain11.ru.       3968    IN      A       8x.2.3x.1x2
    ns2.domain11.ru.       3968    IN      A       8x.2.3x.1x5
    
    ;; Query time: 2 msec
    ;; SERVER: 8x.2x.44.x#53(8x.2x.44.x)
    ;; WHEN: Sat Mar  3 12:27:18 2012
    ;; MSG SIZE  rcvd: 121

    Code:
    # dig all cpanel.domain03.com
    
    ; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> all cpanel.domain03.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 43510
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;all.                           IN      A
    
    ;; AUTHORITY SECTION:
    .                       33093   IN      SOA     a.root-servers.net. nstld.verisign-grs.com. 2012030201 1800 900 604800 86400
    
    ;; Query time: 1 msec
    ;; SERVER: 8x.2x.44.x#53(8x.2x.44.x)
    ;; WHEN: Sat Mar  3 10:27:29 2012
    ;; MSG SIZE  rcvd: 96
    
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57596
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;cpanel.domain03.com.          IN      A
    
    ;; ANSWER SECTION:
    cpanel.domain03.com.   14400   IN      A       8x.2x.35.18x
    
    ;; AUTHORITY SECTION:
    domain03.com.          28085   IN      NS      ns1.domain03.com.
    domain03.com.          28085   IN      NS      ns2.domain03.com.
    
    ;; ADDITIONAL SECTION:
    ns1.domain03.com.      11565   IN      A       8x.2x.35.18x
    ns2.domain03.com.      11565   IN      A       8x.2x.39.21x
    
    ;; Query time: 3 msec
    ;; SERVER: 8x.2x.44.x#53(8x.2x.44.x)
    ;; WHEN: Sat Mar  3 10:27:29 2012
    ;; MSG SIZE  rcvd: 122
     
  4. Jack Plissken

    Jack Plissken Member

    Joined:
    Mar 3, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello, I have this issue. I have two servers
    1st
    WHM 11.30.6 (build 3)
    CENTOS 6.1 x86_64 standard

    2nd
    WHM 11.30.6 (build 3)
    CENTOS 6.2 x86_64 standard

    In 1st server aliases works normal, on 2nd I see "/cgi-sys/defaultwebpage.cgi"
    ============================
    Code:
    # dig all cpanel.domain11.ru
    
    ; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> all cpanel.domain11.ru
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 20999
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;all.                           IN      A
    
    ;; AUTHORITY SECTION:
    .                       33162   IN      SOA     a.root-servers.net. nstld.verisign-grs.com. 2012030201 1800 900 604800 86400
    
    ;; Query time: 21 msec
    ;; SERVER: 8x.2x.44.x#53(8x.2x.44.x)
    ;; WHEN: Sat Mar  3 12:27:18 2012
    ;; MSG SIZE  rcvd: 96
    
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35009
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;cpanel.domain11.ru.           IN      A
    
    ;; ANSWER SECTION:
    cpanel.domain11.ru.    14400   IN      A       8x.2.3x.1x2
    
    ;; AUTHORITY SECTION:
    domain11.ru.           40072   IN      NS      ns2.domain11.ru.
    domain11.ru.           40072   IN      NS      ns1.domain11.ru.
    
    ;; ADDITIONAL SECTION:
    ns1.domain11.ru.       3968    IN      A       8x.2.3x.1x2
    ns2.domain11.ru.       3968    IN      A       8x.2.3x.1x5
    
    ;; Query time: 2 msec
    ;; SERVER: 8x.2x.44.x#53(8x.2x.44.x)
    ;; WHEN: Sat Mar  3 12:27:18 2012
    ;; MSG SIZE  rcvd: 121

    Code:
    # dig all cpanel.domain03.com
    
    ; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> all cpanel.domain03.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 43510
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;all.                           IN      A
    
    ;; AUTHORITY SECTION:
    .                       33093   IN      SOA     a.root-servers.net. nstld.verisign-grs.com. 2012030201 1800 900 604800 86400
    
    ;; Query time: 1 msec
    ;; SERVER: 8x.2x.44.x#53(8x.2x.44.x)
    ;; WHEN: Sat Mar  3 10:27:29 2012
    ;; MSG SIZE  rcvd: 96
    
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57596
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;cpanel.domain03.com.          IN      A
    
    ;; ANSWER SECTION:
    cpanel.domain03.com.   14400   IN      A       8x.2x.35.18x
    
    ;; AUTHORITY SECTION:
    domain03.com.          28085   IN      NS      ns1.domain03.com.
    domain03.com.          28085   IN      NS      ns2.domain03.com.
    
    ;; ADDITIONAL SECTION:
    ns1.domain03.com.      11565   IN      A       8x.2x.35.18x
    ns2.domain03.com.      11565   IN      A       8x.2x.39.21x
    
    ;; Query time: 3 msec
    ;; SERVER: 8x.2x.44.x#53(8x.2x.44.x)
    ;; WHEN: Sat Mar  3 10:27:29 2012
    ;; MSG SIZE  rcvd: 122
     
  5. Jack Plissken

    Jack Plissken Member

    Joined:
    Mar 3, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello. I solved this issue
    faq
    WHM FAQs there a way to access webmail

    In my WHM Main >> Server Configuration >> Tweak Settings I set
    Proxy subdomains off
    Proxy subdomain creation off

    Save
    and again
    Proxy subdomains on
    Proxy subdomain creation on

    And this works !!
     
  6. Jack Plissken

    Jack Plissken Member

    Joined:
    Mar 3, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hmm.. problems again :confused:
    now I see redirect to /cgi-sys/defaultwebpage.cgi and message

    "Could not determine user from environment"


    update
    fixed
    In my WHM Main >> Server Configuration >> Tweak Settings I set
    Proxy subdomains off
    Proxy subdomain creation off

    Save
    and again
    Proxy subdomains on
    Proxy subdomain creation on


    but why c_panel change settings agin?
     
    #6 Jack Plissken, Mar 5, 2012
    Last edited: Mar 5, 2012
  7. Jack Plissken

    Jack Plissken Member

    Joined:
    Mar 3, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello, anybody know about this issue? How work "Proxy subdomain creation" in C_panel?
    Thank you
     
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,468
    Likes Received:
    196
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    cPanel would not change these settings.

    If you've enabled the proxy settings, on both servers, and the account and domain is properly configured, on both servers and you've waited for propagation of the domain(s), it should work. If you've met that criteria you might have some issue here you should have cPanel Support take a closer look at.

    From WHM on the server with the problem, Top right corner of any page is a link titled Support. On it you'll find the link to Contact cPanel.
     
Loading...

Share This Page