The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel donts start auto. after reboot

Discussion in 'General Discussion' started by musti19, Jan 20, 2013.

  1. musti19

    musti19 Well-Known Member

    Joined:
    Jan 20, 2013
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    hi,
    after i changed some mods via easyapache, after a reboot
    cpanel dont start automaticly.
    the websites do work.

    after start cpanel via ssh , everything is ok.
    where can be the problem?

    thank you
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. musti19

    musti19 Well-Known Member

    Joined:
    Jan 20, 2013
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    hi,
    here are the outputs:

    N3
    and
    cpanel 0off 1off 2off 3on 4on 5on 6off

    thank you
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    That indicates cPanel should start normally when your system is rebooted. Are you sure that cPanel is failing to start when your system is rebooted, or are you referring to restarting Apache? Do you notice any specific error messages in /usr/local/cpanel/logs/error_log when cPanel fails to start?

    Thank you.
     
  5. musti19

    musti19 Well-Known Member

    Joined:
    Jan 20, 2013
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    even i rebooted my system, all client pages do work, but not cpanel,
    i start cpanel manually with this messages:
    PHP:
    Starting cPanel servicesWaiting for cpsrvd,cpsrvd-ssl,whostmgrd,cpaneld,webmai                                                                                        ld to shutdown ... not running.
    Starting cpsrvd.
                                                               [  
    OK  ]
    Starting cPanel brute force detector services:             [  OK  ]
    Starting cPanel dav services:                              [  OK  ]
    Starting pop3 servicesWaiting for (?-xism:^cppop(?:-ssl)?$) to shutdown ... no                                                                                        t running.
                                                               [  
    OK  ]
    Starting cPanel Chat services:

    Starting cPanel ssl servicesWaiting for (?-xism:^(?:stunnel$|stunnel-[0-9\.]+l                                                                                        ocal)) to shutdown ... not running.
    Using Native SSL support (stunnel not needed)
                                                               [  
    OK  ]
    Starting cPanel Queue services:                            [  OK  ]
    Starting tailwatchd: [Wed Jan 23 21:12:23 2013Starting /usr/local/cpanel/libex                                                                                        ec/tailwatch/tailwatchd daemon
    Log is at 
    /usr/local/cpanel/logs/tailwatchd_log
                                                               
    [  OK  ]
    Starting cPanel Log services: ==> cPanel Log Daemon version 25.0
                                                               
    [  OK  ]
    Starting mailman services:                                 [  OK  ]
    the error_log file is empty.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  7. siriusb

    siriusb Member

    Joined:
    Mar 10, 2009
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Argentina
    cPanel Access Level:
    Root Administrator
    Hello

    I have the same problem.

    Code:
    root@ws6 [~]# runlevel
    N 3
    root@ws6 [~]# chkconfig|grep cpanel
    cpanel          0:desactivado   1:desactivado   2:desactivado   3:activo        4:activo        5:activo        6:desactivado
    root@ws6 [~]#
    
    Code:
    root@ws6 [~]# service cpanel restart
    Stopping tailwatchd:  [4574] [2013-02-08 02:59:17 -0300] [main] Current process '4115' stopped
                                                               [  OK  ]
    Stopping cPanel services:  Waiting for cpsrvd,cpsrvd-ssl,whostmgrd,cpaneld,webmaild to shutdown ..... terminated.
                                                               [  OK  ]
    Stopping cPanel dav services:  [Fri Feb  8 02:59:18 2013] Current process '4079' stopped
    Waiting for cpdavd,cpdavd-ssl to shutdown ... not running.
                                                               [  OK  ]
    Stopping cPanel queue services:  Graceful shutdown of cPanel TaskQueue Daemon requested. complete
                                                               [  OK  ]
    Stopping cPanel brute force detector services:  Waiting for cphulkd.pl,cPhulkd,cphulkd to shutdown ... not running.
                                                               [  OK  ]
    Stopping pop3 services:  Waiting for (?^:^cppop(?:-ssl)?$) to shutdown ... not running.
                                                               [  OK  ]
    Stopping cPanel log services:                              [FAILED]
    Stopping cPanel Chat services:                             [FAILED]
    Stopping InterChange services:                             [FAILED]
    Stopping cPanel ssl services:  Waiting for (?^:^(?:stunnel$|stunnel-[0-9\.]+local)) to shutdown ... not running.
                                                               [  OK  ]
    Stopping mailman services:  Shutting down Mailman's master qrunner
    PID unreadable in: /usr/local/cpanel/3rdparty/mailman/data/master-qrunner.pid
    [Errno 2] No such file or directory: '/usr/local/cpanel/3rdparty/mailman/data/master-qrunner.pid'
    Is qrunner even running?
    mailmanctl: no process killed
                                                               [FAILED]
    Starting SMTP Tweak: SMTP Mail protection has been enabled.
    All outbound SMTP connctions will be redirected to localhost except:
            uid is root (ports: 25,465,587)
            uid is cpanel (ports: 25,465,587)
            gid is mail (ports: 25,465,587)
            gid is mailman (ports: 25,465,587)
                                                               [  OK  ]
    Starting cPanel services: Waiting for cpsrvd,cpsrvd-ssl,whostmgrd,cpaneld,webmaild to shutdown ... not running.
    Starting cpsrvd.
                                                               [  OK  ]
    Starting cPanel brute force detector services:             [  OK  ]
    Starting cPanel dav services:                              [  OK  ]
    Starting pop3 services: Waiting for (?^:^cppop(?:-ssl)?$) to shutdown ... not running.
                                                               [  OK  ]
    Starting cPanel Chat services:
    
    Starting InterChange services:                             [  OK  ]
    Starting cPanel ssl services: Waiting for (?^:^(?:stunnel$|stunnel-[0-9\.]+local)) to shutdown ... not running.
                                                               [FAILED]
    Starting cPanel Queue services:                            [  OK  ]
    Starting tailwatchd: [Fri Feb  8 02:59:25 2013] Starting /usr/local/cpanel/libexec/tailwatch/tailwatchd daemon
    Log is at /usr/local/cpanel/logs/tailwatchd_log
                                                               [  OK  ]
    Starting cPanel Log services: ==> cPanel Log Daemon version 25.0
                                                               [  OK  ]
    Starting mailman services:                                 [  OK  ]
    root@ws6 [~]#
    
    
    
     
Loading...

Share This Page