SOLVED cpanel-dovecot-solr times out/crashes

ElviCities

Active Member
Aug 9, 2012
27
7
53
cPanel Access Level
Root Administrator
Twitter
With Cpanel 64, we have an awesome new feature w/ solr. However, (on my system at least) it is completely non-functional - as the service fails to start:

Code:
Mar 30 04:29:49 [email protected] systemd[1]: Starting Solr for cPanel Dovecot...
Mar 30 04:29:52 [email protected] solr[9653]: Archiving 1 old GC log files to /home/cpanelsolr/server/logs/archived
Mar 30 04:29:52 [email protected] solr[9653]: Archiving 1 console log files to /home/cpanelsolr/server/logs/archived
Mar 30 04:29:53 [email protected] solr[9653]: Rotating solr logs, keeping a max of 9 generations
Mar 30 04:31:17 [email protected] solr[9653]: [293B blob data]
Mar 30 04:31:21  [email protected] systemd[1]: cpanel-dovecot-solr.service start operation timed out. Terminating.
Mar 30 04:31:21 [email protected] systemd[1]: Failed to start Solr for cPanel Dovecot.
Mar 30 04:31:21 [email protected] systemd[1]: Unit cpanel-dovecot-solr.service entered failed state.
Mar 30 04:31:21 [email protected] systemd[1]: cpanel-dovecot-solr.service failed.
I then discovered that solr uses its own port (8984) - so thinking that opening this port up in CSF would solve the issue, I gave that a shot. No dice.

Every few minutes I get the service up/down failed/recovered notice emails (over the course of the night, a few hundred).

Currently on centos 7.3, running Cpanel 64 build 3.

Thoughts? Ideas? All are welcome!
 

craigedmonds

Well-Known Member
Oct 29, 2007
114
0
66
Europe
cPanel Access Level
Root Administrator
Twitter
An updated RPM with a workaround for systems that cannot run lsof as the user has been released.

You can get it now by running

Code:
yum clean all ; yum update cpanel-dovecot-solr
I have been receiving alert messages every few minutes since I enabled dovecot-solr.

I ran the command above and the service restarted nicely and for 30 minutes was fine but after that I have started receiving the error messages again and they come in every 4 minutes again.