cPanel email issue after updates

Operating System & Version
centos 7
cPanel & WHM Version
92.0.5

ca2236

Well-Known Member
Feb 2, 2018
216
22
18
Nebraska
cPanel Access Level
DataCenter Provider
Hi,

I wanted to post about this strange issue that we seem to be running into. I realize that the premise may be wrong. But it seems like every time cPanel updates, something weird happens with the exim config. We haven't had this issue before. So I don't know if it started with the 92.x series or it is something else (as it is it also a new server spin up).

But after an update happens, then it seems like I have to go back into exim security settings in the config and resave the file. before that, it seems like websites can't send email.

I understand that there are many facets of this.
1) A WordPress site using WP Mail SMTP set to go through an smtp server.
2) The cPanel server itself
3) The receiving mail server.


Here is what is happening, or at least what seems to happen. The server update to a new cPanel version or run another update. WP Mail's email test will fail being able to connect to the receiving mail server with the error

Code:
SMTP Error: The following recipients failed: [email protected] Please turn on SMTP Authentication in your mail client.
(website domain name goes here) [smtp server ip]:45612 is not permitted to relay through this server without authentication.
Please note, I 100% agree that this appears to setting on the mail server, however, the IP space is permitted to relay with authentication. And the more interesting part is that as soon as I go in and save the settings in the exim security configuration itself in cPanel, everything works just fine. There were no changes to the mail server, and no changes to the website or wordpress smtp plugin. Mail just starts flowing again. (until the next apparent update.)

at first, I thought some settings got defaulted, so I changed them to match another server we have, but this time, I didn't do that. I just saved it and it started working.

I appreciate any help you can give in tracking down this strange issue.
 

ca2236

Well-Known Member
Feb 2, 2018
216
22
18
Nebraska
cPanel Access Level
DataCenter Provider
Hi @cPRex,

I can get you the tab. I'm not sure about if it is in cPanel or WHM.(WHM maybe) I just go into here and click save. I used to adjust settings in there, however, this morning, I just clicked save only, so I'm not sure if the setting changes I did before made any difference. :)

Thank you for your help. :)
 

Attachments

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
2,977
378
213
cPanel Access Level
Root Administrator
Thanks for the screenshot. That interface is the WHM >> Exim Configuration Manager, but I would need to know the specific option that is being changed in order to make this work. If you aren't sure what option that is, it would be best to contact our team before any changes are made to the Exim configuration again so we can try and track down the root problem.
 

ca2236

Well-Known Member
Feb 2, 2018
216
22
18
Nebraska
cPanel Access Level
DataCenter Provider
Thanks for the reply, but as I mentioned, I'm not making any changes. I hit the save button and things start working again until the next update that seems to beak it.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
2,977
378
213
cPanel Access Level
Root Administrator
I understand that you aren't personally making any changes, but it seems like *something* on that page must be changing or else it wouldn't be necessary to click the save button at all.

Here's another test that may work to track down the issue if you didn't want to open a ticket. You could create a copy of the exim configuration with the following command:

Code:
cp /etc/exim.conf /etc/exim.conf.original
Then, you could force a cPanel update with this command:

Code:
/scripts/upcp --force
and then finally, compare the changes in your original file with the newly-created version after the update:

Code:
sdiff -s /etc/exim.conf.original /etc/exim.conf
That command would show differences between the files, which would give us a clue as to what is being changed. Could you try that the next time you experience this issue?
 

ca2236

Well-Known Member
Feb 2, 2018
216
22
18
Nebraska
cPanel Access Level
DataCenter Provider
Hello,

I apologize, just getting back to that, I did the commands you said, and upcp did update, but sdiff had no difference in output between exim.conf and exim.conf.original
 

wintech2003

Well-Known Member
PartnerNOC
Sep 15, 2010
103
27
78
Greece
cPanel Access Level
DataCenter Provider
And the more interesting part is that as soon as I go in and save the settings in the exim security configuration itself in cPanel, everything works just fine.
Even if you don't make any changes in your Exim configuration, hitting the Save button will restart Exim which is probably why everything starts working again.

In case this happens again, try restarting Exim from WHM instead of going to the configuration page and hitting the Save button. If restarting Exim indeed helps, then try what cPRex suggested earlier about comparing the good vs bad exim configuration files.
 
  • Like
Reactions: cPRex

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
2,977
378
213
cPanel Access Level
Root Administrator
It would be best to open a ticket to have us investigate the issue. If you can get us details on how we can reproduce the issue, or if you can provide us access to the server through the ticket when the issue hasn't been resolved yet, we'd be happy to look!
 

ca2236

Well-Known Member
Feb 2, 2018
216
22
18
Nebraska
cPanel Access Level
DataCenter Provider
@wintech2003 and @cPRex I re-ran /scripts/upcp --force again to see if the exim service was running afterwards, and
Code:
service exim status
showed that it was. From the command line I restarted exim and it fixed the issue without saving the file

edit, without an update, this might have been a invalid test as I think it only happens when updating. however, I did notice that after forcing upcp, the exim service is not restarted, not sure if it should be, but it wasn't on other servers where we don't seem to have this issue.
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
2,977
378
213
cPanel Access Level
Root Administrator
It looks like we replied at the same time :D

Running "/scripts/upcp --force" would perform a full update, although there may not be an actual update to a new version of the software available each time you run that command. However, the tool will still check and make sure all necessary cPanel files are in place and working properly.
 

ca2236

Well-Known Member
Feb 2, 2018
216
22
18
Nebraska
cPanel Access Level
DataCenter Provider
Thanks for the response @cPRex, however, is there a way we can work through troubleshooting this now? (through forum or otherwise) When the issue happens, I can't leave the server down for half a day to all day waiting for troubleshooting to happen or a technician to call be back within the time frame window, it is a live production server with clients that need their ecommerce orders.

One thing that I know, or it seems to be, is that our smtp server supports both smtp auth and non auth. however, when this happens, even the website we have setup to authenticate to our smtp server does not and generates the same error. It almost acts like it trying to authenticate against itself when this happens and not the smtp server, but I could be wrong, that is how I thought I was reading the exim panic logs though.
 

ca2236

Well-Known Member
Feb 2, 2018
216
22
18
Nebraska
cPanel Access Level
DataCenter Provider
Can you tell me if there was a resolution to this ticket? They opened a support ticket. It sounds very similar to what I am experiencing. though I don't know if my exim.conf.local is affected.

 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
2,977
378
213
cPanel Access Level
Root Administrator
I did see the ticket as submitted, but the user stopped replying so we were never able to perform our testing on that issue. There's no cost to submit a ticket so I'd encourage you to do that if you're seeing the same odd behavior.