keston

Registered
Sep 2, 2004
3
0
151
Hi cpanel, I am contacting you all regarding a problem that I am having with the software on my server. When I go into cpanel>scriptlibary> and try to intall phpbb I get the following error

"phpBB 2.0.8a Setup
We are installing in /home/username/public_html/dds...



There was a problem with the install"

Assistance with the cpanel error will gladly be appreciated.
 

whmapi.scripts

Well-Known Member
Sep 1, 2004
92
0
156
United Kingdom
That last part of your directory tree "/dds..." is there more to it or were you trying to install it in a directory called dds... ? Have you tried to specify a different directory and does the cPanel account in question have enough mysql databases? If all else fails you could always download the latest version 2.0.10 from www.phpbb.com and install it that way?
 

keston

Registered
Sep 2, 2004
3
0
151
cpscripts said:
That last part of your directory tree "/dds..." is there more to it or were you trying to install it in a directory called dds... ? Have you tried to specify a different directory and does the cPanel account in question have enough mysql databases? If all else fails you could always download the latest version 2.0.10 from www.phpbb.com and install it that way?
dds was the directory, and yes there were enough mysql.
 

whmapi.scripts

Well-Known Member
Sep 1, 2004
92
0
156
United Kingdom
Sounds like a cPanel error :(

Do you have root access to the server or do you lease your web space from a hosting company? If the later you will have to contact them and get them to fix the installer and while you're at it you could tell them to upgrade the phpBB core as it's out of date ;)

If you do have root access I could probably tell you how to fix it but I get the impression that you do not so it would be up to your server administrator to sort it out.

Like I said earlier, you could always download it from www.phpbb.com and follow their installation instructions instead? It's pretty easy to install :)
 

keston

Registered
Sep 2, 2004
3
0
151
cpscripts said:
Sounds like a cPanel error :(

Do you have root access to the server or do you lease your web space from a hosting company? If the later you will have to contact them and get them to fix the installer and while you're at it you could tell them to upgrade the phpBB core as it's out of date ;)

If you do have root access I could probably tell you how to fix it but I get the impression that you do not so it would be up to your server administrator to sort it out.

Like I said earlier, you could always download it from www.phpbb.com and follow their installation instructions instead? It's pretty easy to install :)

I have root access, I will install it manually. Can you inform me how to upgrade the installer
 
Last edited:
C

cPanelBilly

Guest
cd /usr/local/cpanel/addons/phpBB
./openinstall

That will fix it.
 

abcc

Member
Sep 27, 2003
19
0
151
We have the same problem on our servers, which are running the latest current release (just updated to make sure).

phpBB 2.0.10 Setup
We are installing in /home/xxxx/public_html/phpbb...



There was a problem with the install!

Have tried running the ./openinstall, and retried - no change.

Any ideas?
 

abcc

Member
Sep 27, 2003
19
0
151
Sorted

This worked for me:

At a shell prompt:
/scripts/updatenow
/scripts/upcp --force