The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel / Exim Unusual Behavior

Discussion in 'General Discussion' started by Ali, Sep 5, 2005.

  1. Ali

    Ali Well-Known Member

    Joined:
    Jul 12, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    I’m running the latest Release build (WHM 10.6.0 cPanel 10.6.0-R158) + exim-4.52-7 on Fedora Core 3. For some reason the View Relayers in WHM shows that the emails for Domains have been relayed by user “cpanel” instead of the Domains true user. I know this maybe the case when using web-mail but not with Email Clients but yet the stats show "cpanel".

    Another issue is that one of the users is complaining that it takes too long to send emails (90 Seconds to 2 Minutes :().

    I think there is a bug as nobody@hostname.domain.com are being sent to root which is resulting to users emails ending up on the root forwarded mailbox.

    The other issue is a user has selected Default emails to be sent to an address which doesn’t exist :confused: however all those emails are going to nobody@hostname.domain.com which in turn goes to root.

    I’ll appreciate everyones input on this.

    Thanks !
     
    #1 Ali, Sep 5, 2005
    Last edited: Sep 5, 2005
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Have you considered the possibility that no other relaying is taking place?

    If users, through their email clients, choose to use SMTP authentication, they won't be relaying.

    In what way have you tested this? Have you tried sending emails to see how long it takes? If, when testing, you find that emails don't take too long there are only a couple of possible reasons, both client related: 1 - your client is on a slow or unreliable Internet connection, 2 - the route that data travels to get from your client to your server is congested somewhere.

    Check WHM > Server Contacts > Change System Mail Preferences to see where you have set nobody's mail to go.

    I wouldn't at all be surprised if something that seems unexpected happens if a user does this!
     
  3. Ali

    Ali Well-Known Member

    Joined:
    Jul 12, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    My other cpanel boxes have the same configuration (with SMTP authentication requirement) before allowing relay and show relay stats correctly.

    I have tried that on my end and it works just fine. :confused:

    Its blank.

    :D
     
  4. Ali

    Ali Well-Known Member

    Joined:
    Jul 12, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Can someone please help me stop 'nobody' email forwards. In WHM System Mail Preferences its blank yet it says 'currently being forwarded to '.

    How do I reject emails for users who have exceeded their email quotas ?
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You can set the nobody's email to :blackhole: I believe, but you are of course depriving yourself of legitimate bounces.

    You can reject email to full mailboxes with WHM > Exim Configuration Editor > Discard emails for users who have exceeded their quota instead of keeping them in the queue
     
  6. Ali

    Ali Well-Known Member

    Joined:
    Jul 12, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    I want the bounces to go back to the senders and not myself (like it used to in earlier versions of cpanel and/or exim).

    It seems to discard mails ( something like :blackhole: ) whereas I would like to reject it with a error to the sender that mailbox is full.
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    They can't. They're bounces coming back from email sent out by scripts where the recipients do not exist. They have to be delivered somewhere (as per the RFC's) and as such the nobody's email should be set up as a valid email address. The only way around that is for the php scripts to be modified to correctly set the From: and Return-Path: header records or to switch to using phpsuexec.
     
  8. Ali

    Ali Well-Known Member

    Joined:
    Jul 12, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    :blackhole: doesnt seem to work for nobody forwards :confused:
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Then just set it to be empty.
     
  10. Ali

    Ali Well-Known Member

    Joined:
    Jul 12, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    I tried that before using :blackhole: - no luck :(
     
  11. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Last idea, set it to /dev/null
     
  12. Ali

    Ali Well-Known Member

    Joined:
    Jul 12, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    No luck. What file do I need to touch to set this from shell ?
     
Loading...

Share This Page