The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel Forwarders Dont Delete

Discussion in 'General Discussion' started by whipanor7, Feb 2, 2007.

  1. whipanor7

    whipanor7 Member

    Joined:
    Feb 2, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to delete some forwarders in cpanel. They say they are deleted but when I go back it shows them again. I've reset my cache and all and still same thing.

    I also tried pico /etc/valiases/domain.com and deleted them and saved it but they still show up on cpanel. Any idea how to get rid of these?
     
  2. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    451
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Vancouver, Canada
    If you deleted the forwarders from /etc/valiases/domain.com, then they are definitely gone. I get the feeling your browser cached the cPanel forwarders, and therefore keeps on showing you the old info.

    What happens if you add a forwarder in cPanel. Do you see the new forwarder and the old deleted ones?
     
  3. whipanor7

    whipanor7 Member

    Joined:
    Feb 2, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Yes I see the old forwarder and the new one I created if I create a new forwarder. I tried my browser cache that was the first thing I did and it didnt seem to solve the problem.
     
  4. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    451
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Vancouver, Canada
    If you see the new forwarder too, then I am wrong about the browser cache. I am not aware of any other location where forwarders are saved than /etc/valiases/domain.com.

    Sound like it's time to open a support request ;)
     
  5. whipanor7

    whipanor7 Member

    Joined:
    Feb 2, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Yeah I did that. Lets see what they say. I thought that was wierd too, I figured I ask here anyways because I was stuck.
     
  6. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    Did they ever find the issue with this, we haev the same issue ona domain name, can not delete them, they do not show in valiases but still in cpanel. We haev tried evrything to remove these darn things.
     
  7. swbrains

    swbrains Active Member

    Joined:
    Sep 13, 2006
    Messages:
    40
    Likes Received:
    2
    Trophy Points:
    8
    Same Problem (2010)

    I found this thread because I have the same problem under cPabel 11.24.5-STABLE 38506. I can delete a forwarder if the target is a valid email address, but if it's a user ID of a mailbox set up on that account, it says it's deleted but it's really not. My server provider then has to go in and manually delete them for me since I don't have root access.

    It's very inconvenient as I have the need to add and delete different forwarders somewhat frequently on some of my accounts, so I end up with lots of useless forwarders stuck in the list.
     
  8. Youchoose

    Youchoose Registered

    Joined:
    Apr 25, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Same problem

    Did anyone have an answer yet for this, I am experiencing the same issue on;
    cPanel 11.25.0-R44718 - WHM 11.25.0 - X 3.9
     
  9. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    When attempting to remove an e-mail forwarder, what messages are logged in the cPanel error_log?

    Root access is needed to check this specific log, but it may be found at the following filesystem path:
    Code:
    /usr/local/cpanel/logs/error_log
     
  10. jebcom

    jebcom Registered

    Joined:
    Feb 22, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
  11. tjsolu

    tjsolu Registered
    PartnerNOC

    Joined:
    Aug 16, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have this problem too.
     
  12. vavayi

    vavayi Member

    Joined:
    Aug 4, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Try /scripts/upcp
     
  13. mswebguru

    mswebguru Member

    Joined:
    Dec 14, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Philippines
    Hello!

    Is there somebody fixed this issue since I'm getting this error also on our server.

    cPanel 11.25.0-S46156 - WHM 11.25.0 - X 3.9

    Hope someone can provide us how to fix this error.

    Thanks in advance!
     
  14. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Thank you for the log information; I believe it will be necessary to obtain more specific details through a thorough investigation via a support request.

    To accurately diagnose and properly investigate the described symptom it is necessary to do so via "root" (Administrator) access; accordingly, it will help immensely if you submit a support request so that we may directly inspect the system and surrounding circumstances. Upon submitting a support request please send me your ticket ID number so that we may follow-up internally. For reference, the links in my forums signature may be used to initiate a ticket submission (e.g., Support Options).

    Upon confirmation of the cause specific to the circumstances on your server, which can be explicitly requested in the initial support request, you are welcome to share applicable resolution information in the forums thread so that others may benefit as well; if there is any difficulty determining the cause you are welcome to send me a private message (PM) in reference to your ticket submission.
     
    #14 cPanelDon, Jun 18, 2010
    Last edited: Jun 18, 2010
  15. jebcom

    jebcom Registered

    Joined:
    Feb 22, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    work-around

    I can't open a cPanel ticket; my NOC has to do that, so I opened a ticket with them. They told me that it's a bug with the monsoon interface. They were able to delete the forwarders by switching to the x3 interface.
     
  16. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Monsoon theme is deprecated

    The Monsoon theme is deprecated, as well as the Blue Lagoon and X themes. No further development work is being done on these themes.

    There are X and Blue Lagoon skins available for the X3 theme. To use one of these skins, change the theme for the account to X3, then log into the account's cPanel and use the "Change Style" option. There is no Monsoon skin for the X3 theme, but the Blue Lagoon skin is similar and is going to be the closest option available that is currently developed and known to work with current versions of cPanel.
     
Loading...

Share This Page