Cpanel Forwarders Dont Delete

whipanor7

Member
Feb 2, 2007
6
0
151
I am trying to delete some forwarders in cpanel. They say they are deleted but when I go back it shows them again. I've reset my cache and all and still same thing.

I also tried pico /etc/valiases/domain.com and deleted them and saved it but they still show up on cpanel. Any idea how to get rid of these?
 

Stefaans

Well-Known Member
Mar 5, 2002
461
4
318
Vancouver, Canada
If you deleted the forwarders from /etc/valiases/domain.com, then they are definitely gone. I get the feeling your browser cached the cPanel forwarders, and therefore keeps on showing you the old info.

What happens if you add a forwarder in cPanel. Do you see the new forwarder and the old deleted ones?
 

whipanor7

Member
Feb 2, 2007
6
0
151
Yes I see the old forwarder and the new one I created if I create a new forwarder. I tried my browser cache that was the first thing I did and it didnt seem to solve the problem.
 

Stefaans

Well-Known Member
Mar 5, 2002
461
4
318
Vancouver, Canada
If you see the new forwarder too, then I am wrong about the browser cache. I am not aware of any other location where forwarders are saved than /etc/valiases/domain.com.

Sound like it's time to open a support request ;)
 

whipanor7

Member
Feb 2, 2007
6
0
151
Yeah I did that. Lets see what they say. I thought that was wierd too, I figured I ask here anyways because I was stuck.
 

jackal

Well-Known Member
PartnerNOC
Feb 23, 2002
707
0
316
Did they ever find the issue with this, we haev the same issue ona domain name, can not delete them, they do not show in valiases but still in cpanel. We haev tried evrything to remove these darn things.
 

swbrains

Well-Known Member
Sep 13, 2006
218
29
178
Same Problem (2010)

I found this thread because I have the same problem under cPabel 11.24.5-STABLE 38506. I can delete a forwarder if the target is a valid email address, but if it's a user ID of a mailbox set up on that account, it says it's deleted but it's really not. My server provider then has to go in and manually delete them for me since I don't have root access.

It's very inconvenient as I have the need to add and delete different forwarders somewhat frequently on some of my accounts, so I end up with lots of useless forwarders stuck in the list.
 

Youchoose

Registered
Apr 25, 2010
1
0
51
Same problem

Did anyone have an answer yet for this, I am experiencing the same issue on;
cPanel 11.25.0-R44718 - WHM 11.25.0 - X 3.9
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
I found this thread because I have the same problem under cPabel 11.24.5-STABLE 38506. I can delete a forwarder if the target is a valid email address, but if it's a user ID of a mailbox set up on that account, it says it's deleted but it's really not. My server provider then has to go in and manually delete them for me since I don't have root access.

It's very inconvenient as I have the need to add and delete different forwarders somewhat frequently on some of my accounts, so I end up with lots of useless forwarders stuck in the list.
Did anyone have an answer yet for this, I am experiencing the same issue on;
cPanel 11.25.0-R44718 - WHM 11.25.0 - X 3.9
When attempting to remove an e-mail forwarder, what messages are logged in the cPanel error_log?

Root access is needed to check this specific log, but it may be found at the following filesystem path:
Code:
/usr/local/cpanel/logs/error_log
 

mswebguru

Member
Dec 14, 2006
10
0
151
Philippines
Hello!

Is there somebody fixed this issue since I'm getting this error also on our server.

cPanel 11.25.0-S46156 - WHM 11.25.0 - X 3.9

Hope someone can provide us how to fix this error.

Thanks in advance!
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
11.25.0-RELEASE 46156

the error_log entry:
[2010-06-06 17:39:52 -0500] info [cpanel] Unable to locate forwarder "" for account [email protected][email protected] on domain xxxxxxxxxxxxx.com

and after I try to delete, the Forwarding Maintenance page in cPanel says this:
[email protected][email protected]'s mail will no longer be redirected to .
Thank you for the log information; I believe it will be necessary to obtain more specific details through a thorough investigation via a support request.

I have this problem too.
Hello!

Is there somebody fixed this issue since I'm getting this error also on our server.

cPanel 11.25.0-S46156 - WHM 11.25.0 - X 3.9

Hope someone can provide us how to fix this error.

Thanks in advance!
To accurately diagnose and properly investigate the described symptom it is necessary to do so via "root" (Administrator) access; accordingly, it will help immensely if you submit a support request so that we may directly inspect the system and surrounding circumstances. Upon submitting a support request please send me your ticket ID number so that we may follow-up internally. For reference, the links in my forums signature may be used to initiate a ticket submission (e.g., Support Options).

Upon confirmation of the cause specific to the circumstances on your server, which can be explicitly requested in the initial support request, you are welcome to share applicable resolution information in the forums thread so that others may benefit as well; if there is any difficulty determining the cause you are welcome to send me a private message (PM) in reference to your ticket submission.
 
Last edited:

jebcom

Registered
Feb 22, 2010
2
0
51
work-around

I can't open a cPanel ticket; my NOC has to do that, so I opened a ticket with them. They told me that it's a bug with the monsoon interface. They were able to delete the forwarders by switching to the x3 interface.
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
24
143
Houston, TX
cPanel Access Level
Root Administrator
Monsoon theme is deprecated

They told me that it's a bug with the monsoon interface. They were able to delete the forwarders by switching to the x3 interface.
The Monsoon theme is deprecated, as well as the Blue Lagoon and X themes. No further development work is being done on these themes.

There are X and Blue Lagoon skins available for the X3 theme. To use one of these skins, change the theme for the account to X3, then log into the account's cPanel and use the "Change Style" option. There is no Monsoon skin for the X3 theme, but the Blue Lagoon skin is similar and is going to be the closest option available that is currently developed and known to work with current versions of cPanel.