The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel frames problem with Horde logout

Discussion in 'General Discussion' started by krick, Oct 7, 2004.

  1. krick

    krick Registered

    Joined:
    Oct 7, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    When I log out of horde webmail, it leaves the HTML navigation frame
    at bottom of the screen.

    If I repeatedly log out, then in again, it adds another frame each
    time...

    [​IMG]

    I've contacted my web host and they assure me that it's a problem with the way cpanel handles frames and they can't do anything about it.

    Try logging into my webmail and see if it happens for you...

    http://3feetunder.com:2095/
    username: test@3feetunder.com
    password: test

    ...select "horde", login, then logout.

    lather, rinse, repeat.


    I'm not an expert or anything but it seems to me that either the target of the logout button has to be set to _TOP or the "You have been logged out" page needs to have some "frame buster" javascript added to it...

    if(parent != window){
    parent.location = location.href;
    }

    ...
    Krick
     
  2. Sash

    Sash Well-Known Member

    Joined:
    Feb 18, 2003
    Messages:
    252
    Likes Received:
    0
    Trophy Points:
    16
    Anyone come up with a fix for this?

    Thanks
    Mike
     
  3. d-woo

    d-woo Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Problem: Horde Login does not login as target=_top so when logging off one email account and relogging into a new email account the frames stack up.

    Change in the following file:
    /usr/local/cpanel/base/webmaillogin.cgi

    In lines 43 and 44
    change from: <a href="/horde/index.php">
    change to: <a href="/horde/index.php" target=_top>

    And also 32 and 33
    change to: <a href="$webmail->{urlbase}/neomail/neomail.pl" target=_top>

    Be certain that the file is chown as group:wheel and owner:root
    and chmod as 755
    As long as you change the file directly on the box you are okay.

    Hope this helps! ;)
     
  4. krick

    krick Registered

    Joined:
    Oct 7, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I figured the fix was something like that.

    However I am reporting this as an end user and have no way of changing these files.

    Can someone get this fix into the next build of CPanel so my web host can update it?
     
  5. rmbnet

    rmbnet Well-Known Member

    Joined:
    Feb 22, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Best bet in that case is to email your hosting provider (assuming they have root access) to change those settings. requires minimal effort.

    Robert Butler
    Rocky Mountain Business Networks
    http://www.rmbnet.com
     
  6. krick

    krick Registered

    Joined:
    Oct 7, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1

    I already asked them. They say that they don't want to make the changes on their multiple servers and even if they did, they would be overwritten each time they upgrade cPanel and would have to be made again. They instructed me to post here to try to get it fixed in the cPanel software itself.
     
Loading...

Share This Page