The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel + FreeBSD some problems...

Discussion in 'General Discussion' started by ozberk, Jul 28, 2007.

  1. ozberk

    ozberk Registered

    Joined:
    Oct 7, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    Firstly i am sorry for my bad english =)

    I use FREEBSD 6.2+CPanel 11 Current.

    .php files dont work in my server, it gives 500 internal server error.

    i tried to update apache. give error again.

    error:
    configure: error: Problem with libXpm.(a|so) or libX11.(a|so). Please check config.log for more information


    i tried to;
    cd /usr/ports/x11/xorg-libraries
    make install

    but it wasnt effectual.

    what should i do ?


    thx.
     
  2. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    What was your solution to this problem ?
     
  3. XzaB

    XzaB Active Member

    Joined:
    Nov 20, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Egypt, Cairo
    is seems to be LibX11 Corrupted or Missing Library

    anyway try first

    Code:
    cd /usr/ports/x11/libX11/
    make deinstall
    make install
    
    then try to recompile Apache Again,

    anyway if u trying to downgrade Apache i think is will fail and it will cause u many failures if ur Machine is old !

    also Error 500 for php is could be from phpsuexec or suphp try to make it off or maybe Mimes

    anyway try to check Apache Log !
     
  4. moslemovic

    moslemovic Member
    PartnerNOC

    Joined:
    May 25, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Help Me !!!

    My Hosting Server Error now
    and have complaint every customer !!!
    This problem happen after update apache and php to php 5
    i'm using FreeBSD whosting.giga.net.id 6.1-RELEASE

    step error is
    1. I'm open whm
    2. software
    3. chose apache update
    next
    next

    arrive this
    -------------------------------------------------------------------
    php.conf updated to:

    # This file was automatically generated by the Cpanel PHP Configuration system
    # If you wish to change the way PHP is being handled by Apache on your system,
    # use the /usr/local/cpanel/bin/rebuild_phpconf script or the WHM interface.
    #
    # Manual edits of this file will be lost when Apache is updated.


    # SuPHP configuration for PHP5
    LoadModule suphp_module modules/mod_suphp.so
    suPHP_Engine on
    AddType application/x-httpd-php5 .php5 .php4 .php .php3 .php2 .phtml
    <Directory />
    suPHP_AddHandler application/x-httpd-php5
    </Directory>
    <Files *.php5>
    suPHP_AddHandler application/x-httpd-php5
    </Files>
    <Files *.php4>
    suPHP_AddHandler application/x-httpd-php5
    </Files>
    <Files *.php>
    suPHP_AddHandler application/x-httpd-php5
    </Files>
    <Files *.php3>
    suPHP_AddHandler application/x-httpd-php5
    </Files>
    <Files *.php2>
    suPHP_AddHandler application/x-httpd-php5
    </Files>
    <Files *.phtml>
    suPHP_AddHandler application/x-httpd-php5
    </Files>

    # End of autogenerated PHP configuration.


    Updating user configurable PHP settings.
    Restarting Apache
    /usr/local/etc/rc.d/030httpd.sh start: httpd started

    and i test browser

    --------------------------------
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@usbrj.ac.id and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.6 (Unix) mod_ssl/2.2.6 OpenSSL/0.9.8d FrontPage/5.0.2.2635 mod_auth_passthrough/2.1 mod_bwlimited/1.4 Server at usbrj.ac.id Port 80




    help me for this problem




    all thanks from me


    Moslemovic
     
Loading...

Share This Page