The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED cPanel fresh install stuck

Discussion in 'General Discussion' started by Linux_man, Apr 11, 2017.

Tags:
  1. Linux_man

    Linux_man Member

    Joined:
    Oct 21, 2016
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Costa Rica
    cPanel Access Level:
    Root Administrator
    Hello, i have installed cPanel lots of times, but i today in a new and fresh vps server with centOS 7, the installation is stuck at

    -11 17:38:40 219 (DEBUG): Starting filelimits (via systemctl): [ OK ]
    2017-04-11 17:38:40 219 (DEBUG): *** Done legacy_cfg_installer ***
    2017-04-11 17:38:40 219 (DEBUG): *** Running import_old_support_cfg ***
    2017-04-11 17:38:40 219 (DEBUG): *** Done import_old_support_cfg ***
    2017-04-11 17:38:40 219 (DEBUG): *** Running corecleanup ***
    2017-04-11 17:38:40 219 (DEBUG): *** Done corecleanup ***
    2017-04-11 17:38:40 219 (DEBUG): *** Running install_cpaddons ***

    its been now 25 minutes in that step, and no progress at all... its the first time it takes that long... so im not sure if it's any kind of issue or i just need to wait more...

    thanks in advance for your help
     
  2. jamiepenner

    jamiepenner Member

    Joined:
    Aug 30, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Vancouver Island, BC
    cPanel Access Level:
    Root Administrator
    Yup, I've got the same thing happening here on an upgrade. Got one server done about an hour and now it's stuck in the same spot as you. Must be a server issue on their end.
     
  3. Atonium

    Atonium Registered

    Joined:
    Apr 11, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    St. Louis
    cPanel Access Level:
    Root Administrator
    Code:
    [root@ns2 ~]# tail /var/log/cpanel-install.log
    2017-04-11 11:06:43  204 (DEBUG):           'systemctl list-dependencies [target]'.
    2017-04-11 11:06:43  204 (DEBUG):
    2017-04-11 11:06:43  204 (DEBUG):     filelimits        0:off   1:off   2:on    3:on    4:on    5:on    6:off
    2017-04-11 11:06:43  204 (DEBUG):     Starting filelimits (via systemctl):  [  OK  ]
    2017-04-11 11:06:43  204 (DEBUG):     *** Done legacy_cfg_installer ***
    2017-04-11 11:06:43  204 (DEBUG):     *** Running import_old_support_cfg ***
    2017-04-11 11:06:43  204 (DEBUG):     *** Done import_old_support_cfg ***
    2017-04-11 11:06:43  204 (DEBUG):     *** Running corecleanup ***
    2017-04-11 11:06:43  204 (DEBUG):     *** Done corecleanup ***
    2017-04-11 11:06:43  204 (DEBUG):     *** Running install_cpaddons ***
    [root@ns2 ~]#
    Been stuck there for over 3 hours..

    Code:
    [root@ns2 ~]# free -h
                  total        used        free      shared  buff/cache   available
    Mem:           1.9G        435M        180M         23M        1.3G        1.4G
    Swap:          2.0G        288K        2.0G
    [root@ns2 ~]# cat /proc/cpuinfo
    processor       : 0
    vendor_id       : GenuineIntel
    cpu family      : 6
    model           : 42
    model name      : Intel Xeon E312xx (Sandy Bridge)
    stepping        : 1
    microcode       : 0x1
    cpu MHz         : 2599.998
    cache size      : 4096 KB
    physical id     : 0
    siblings        : 1
    core id         : 0
    cpu cores       : 1
    apicid          : 0
    initial apicid  : 0
    fpu             : yes
    fpu_exception   : yes
    cpuid level     : 13
    wp              : yes
    flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx rdtscp lm constant_tsc rep_good nopl xtopology eagerfpu pni pclmulqdq ssse3 cx16 sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx hypervisor lahf_lm arat xsaveopt
    bogomips        : 5199.99
    clflush size    : 64
    cache_alignment : 64
    address sizes   : 40 bits physical, 48 bits virtual
    power management:
    
    [root@ns2 ~]# ps aux | grep cpanel
    root      2268  0.0  0.2  30220  4624 ?        S    11:04   0:00 /usr/local/cpanel/3rdparty/bin/perl /usr/local/cpanel/scripts/post_sync_cleanup --log=/var/cpanel/updatelogs/update.1491922994.log --pbar-start=30 --pbar-stop=55
    root      2271  0.0  3.5 175692 70052 ?        S    11:04   0:00 /usr/local/cpanel/bin/taskrun
    cpanelc+  2774  0.1  0.2  13136  4796 ?        Ss   11:06   0:21 /usr/local/cpanel/3rdparty/sbin/p0f -i any -u cpanelconnecttrack -d -s /var/cpanel/userhomes/cpanelconnecttrack/p0f.socket less 400 and not dst port 80 and not dst port 443 and tcp[13] & 8==0
    root      3201  0.0  0.1  26420  2644 ?        S    11:06   0:00 /usr/local/cpanel/3rdparty/bin/perl /usr/local/cpanel/bin/install_cpaddons
    root      3202  0.0  1.5  82844 30324 ?        S    11:06   0:00 /usr/local/cpanel/whostmgr/docroot/cgi/cpaddons.pl
    root      3205  0.0  0.8  68316 16040 ?        S    11:06   0:00 /usr/local/cpanel/3rdparty/bin/perl /usr/local/cpanel/scripts/cpanelsync --signed=1 httpupdate.cpanel.net /cpanelsync/cpaddons/cPAddonsMD5 /usr/local/cpanel/cpaddons/cPAddonsMD5
    root      8117  0.0  0.0 112648   964 pts/0    R+   14:23   0:00 grep --color=auto cpanel
    root     29801  0.0  2.6 111948 53500 tty1     S+   10:44   0:12 /usr/local/cpanel/scripts/cpanel_initial_install
    [root@ns2 ~]#
    
    
    I have access to hostname:2087 but the install has been stuck there for over 3 hours. This is the first time I've installed on a VPS but I didn't think it'd take as long as it is. Anyone have any suggestions or tips? Is it normal? Should I just wait longer?
     
  4. jamiepenner

    jamiepenner Member

    Joined:
    Aug 30, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Vancouver Island, BC
    cPanel Access Level:
    Root Administrator
    This is definitely not normal.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,297
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I've opened a case with our System Administration team to report this issue. We'll update this thread with more information as it becomes available.

    Thank you.
     
    Linux_man, jamiepenner and Atonium like this.
  6. Linux_man

    Linux_man Member

    Joined:
    Oct 21, 2016
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Costa Rica
    cPanel Access Level:
    Root Administrator
    Thank god (and sorry for that) i'm not alone with the issue... i already tried reinstalling from zero even the OS 3 times now just to check... but still the same, stuck in the same place... hopefully this can be resolved soon...
     
  7. jvandellen

    jvandellen Member
    PartnerNOC

    Joined:
    Jun 19, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    51
  8. jamiepenner

    jamiepenner Member

    Joined:
    Aug 30, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Vancouver Island, BC
    cPanel Access Level:
    Root Administrator
  9. jvandellen

    jvandellen Member
    PartnerNOC

    Joined:
    Jun 19, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    51
    Am I going to need to restart these installs?
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,297
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Our System Administration team has fixed the issue with the update mirrors, however the changes could take a few minutes to fully sync. Please wait a few more minutes and let us know if the installation continues to hang.

    Thank you.
     
    Atonium likes this.
  11. Atonium

    Atonium Registered

    Joined:
    Apr 11, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    St. Louis
    cPanel Access Level:
    Root Administrator
    I'm an absolute noob regarding cPanel but if the problem is truly is a problem with one of their servers and the "Running install_cpaddons" hasn't timed out for me by now, I'd imagine the installation will continue when access to the server is restored.
     
  12. jamiepenner

    jamiepenner Member

    Joined:
    Aug 30, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Vancouver Island, BC
    cPanel Access Level:
    Root Administrator
    I killed off my update process since it was still stuck at that stage. Ran the update again and it worked fine (thought it was hanging again but got going after about 10 seconds)....
     
  13. Linux_man

    Linux_man Member

    Joined:
    Oct 21, 2016
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Costa Rica
    cPanel Access Level:
    Root Administrator
    yup problem solved, i just checked and cpanel finished the install, :) thanks a lot you are the bests...
     
    cPanelMichael likes this.
Loading...

Share This Page