SOLVED cPanel has Ioncube Loader higher than v5.1.1 ?

SuperBaby

Well-Known Member
Nov 27, 2003
343
0
166
Thailand
cPanel Access Level
Website Owner
Twitter
My server is running CENTOS 6.9 + cPanel. The Ioncube Loader is version 5.1.1 which is the latest version available included in cPanel's WHM >> EasyApache 3.

Why I try to update a script called FILE RUN, I get this error:

Fatal error: The file /home/xxxxx/public_html/upload/system/data/temp/_unzipped_update/update.php cannot be decoded by this version of the ionCube Loader. If you are the administrator of this site then please install the latest version of the ionCube Loader.
in Unknown on line 0

Ioncube Loader version 5.1.1 is not enough? What can I do?
 

Muhammed Fasal

Well-Known Member
Aug 9, 2017
54
10
8
India
cPanel Access Level
Root Administrator
Hi :)

The latest IonCube Loader would be "ioncube_loader_lin_7.1.so". You can download this from their official site.
I could see another thread in which I have already explained the installation steps:;)

wrong Ioncube Loader being loaded

note that: you need to change the download URL based on your server architecture.

32bit system:
64bit system:
 

SuperBaby

Well-Known Member
Nov 27, 2003
343
0
166
Thailand
cPanel Access Level
Website Owner
Twitter
Hi :)

The latest IonCube Loader would be "ioncube_loader_lin_7.1.so". You can download this from their official site.
I could see another thread in which I have already......
Thanks, Fasal. I followed your old post and also used the Loader Wizard. Now my IonCube Loader is v10.x.x
 

SuperBaby

Well-Known Member
Nov 27, 2003
343
0
166
Thailand
cPanel Access Level
Website Owner
Twitter
One more thing....

Now I am running IonCube Loader v10.x.x successfully. I take a look under EasyApache3 and still see a tick for the checkbox "IonCube 5 Loader v5.1.1 for PHP".

Do I untick this during my next EasyApache3 update? I am worry cPanel will overwrite v10.x with v5.1.1

Thanks.
 

Muhammed Fasal

Well-Known Member
Aug 9, 2017
54
10
8
India
cPanel Access Level
Root Administrator
Thanks, Fasal. I followed your old post and also used the Loader Wizard. Now my IonCube Loader is v10.x.x
First of all, glad to hear that it's working out for you! ;)

Do I untick this during my next EasyApache3 update? I am worry cPanel will overwrite v10.x with v5.1.1
Yes, you can safely untick v5.1.1 option. The Ioncube loader will be safe as v10.x