Cpanel HTTPD and other services won't start

praveenkv1988

Member
May 21, 2007
14
0
151
Trivandrum
Hello,

I am using xen for virtualization
The host is 64 bit centos 5.2

And guest os is 32 bit centos 5.2
When I look the uname -a on guest os it shows
Code:
2.6.18-92.1.18.el5xen #1 SMP Wed Nov 12 09:48:10 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
But this is a 32 bit OS.

I have done the following to make the yum grab 32 bit packages.
Code:
echo i686-redhat-linux > /etc/rpm/platform
Now the yum works good. But when I install cpanel it grabs the x86_64 packages. How can I make the cpanel installer to grab 32 bit packages???

Where will the installer look to find the OS version(32 bit or 64 bit)???

plz. reply soon.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
If you are using paravirtualization, then install a 32-bit kernel for the Guest to use.
 

praveenkv1988

Member
May 21, 2007
14
0
151
Trivandrum
Yes, I use paravirtualization. I have installed i386 centos 5. But the uname -a displays it as 64 bit.

When I install cpanel it grabs packages for 64 bit. How can I force cpanel installer to use 32 bit packages.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
Yes, I use paravirtualization. I have installed i386 centos 5. But the uname -a displays it as 64 bit.

When I install cpanel it grabs packages for 64 bit. How can I force cpanel installer to use 32 bit packages.
You have to install a 32-bit kernel for the guest to use, then change the Guest configuration to boot from that kernel.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
It depends upon the tools used to configure and use Xen in your environment. Typically, you just need to modify the configuration file Xen uses to start the guest. The kernel and ramdisk entries need updated to point to the proper kernel and initrd image. Please note, the 32-bit kernel must have the Xen extensions enabled since you are using Paravirtualization.

Once the configuration is updated, restart the guest.
 

praveenkv1988

Member
May 21, 2007
14
0
151
Trivandrum
I have changed the kernel and ramdisk to the one provided by centos for xen virtualization with xen.

Even after that the uname -a gives the same output.