The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel ignores MX record when sending mail

Discussion in 'E-mail Discussions' started by Silver_2000, Jun 30, 2010.

  1. Silver_2000

    Silver_2000 Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    338
    Likes Received:
    1
    Trophy Points:
    18
    I moved the email for one account from the server to gmail to allow wireless sync to mobile devices. All email from the server and elsewhere properly gets routed to gmail for that domain.

    EXCEPT email sent to previous mailman mailing list address. 2 months ago, I moved the list to google groups, and it works fine until an account on the server attempts to send to the address. Those emails get routed locally. If you use the "Email Delivery Route" tester in Cpanel it comes up blank for the list address and shows the correct postini mx address for other addresses on the same domain.

    I know that I could / should delete the list to potentially solve the problem BUT I wanted to retain the archives.

    There has to be a way to fix the servers handling of this one email address ...

    Any ideas ??
     
  2. heyjohnboy

    heyjohnboy Well-Known Member

    Joined:
    Oct 7, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Valencia, CA
    Look to see if the domain is still in /etc/localdomains. If it is, cpanel bypasses the MX setting because it's a local address. If you find it in there, delete it and place it in /etc/remotedomains to avoid having it re-creating itself.
     
  3. Silver_2000

    Silver_2000 Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    338
    Likes Received:
    1
    Trophy Points:
    18
    its only in remotedomains
     
Loading...

Share This Page