The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel install error on freebsd

Discussion in 'General Discussion' started by makoy, Jul 9, 2007.

  1. makoy

    makoy Member

    Joined:
    May 18, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi, I have a freebsd 6.1 installed on my server and I'm having a problem in installing cpanel on it.. here's the error... I hope you guys could help me solve this problem. Thanks:D

    # sh latest
    Creating directory installd
    Verifying archive integrity... All good.
    Uncompressing cplyr1-cPanel......................................................
    ...............................................................................................
    ...............................................................................................
    ...............................................................................................
    ...............................................................................................
    ...............................................................................................
    ...............................................................................................
    ...............................................................................................
    ...............................................................................................
    ..............................................................................
    ____ _
    ___| _ \ __ _ _ __ ___| |
    / __| |_) / _` | '_ \ / _ \ |
    | (__| __/ (_| | | | | __/ |
    \___|_| \__,_|_| |_|\___|_|

    Installer Version 11.4.1



    Fatal! perl must be installed before proceeding
     
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Try the following:

    # cd /usr/ports/lang/perlx
    # make
    # make install

    where x, is the perl version.
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I would recommend Perl version 5.8.8.
     
  4. makoy

    makoy Member

    Joined:
    May 18, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for your help. It fixed the problem.
     
Loading...

Share This Page