CPanel installation issue on Fresh CentOS

venomdog

Member
Apr 9, 2014
7
0
1
cPanel Access Level
Root Administrator
Hi,
I am trying to install Cpanel on fresh Centos 64 bit and installation freezes for 1 hr or so at Named and following is the error :

Code:
2014-04-28 22:40:56 366 (DEBUG): pure-authd (/usr/sbin/pure-authd -s /var/run/ftpd.sock -r /usr/local/cpanel/bin/pureauth) running as root with PID 11490 (pidfile check method)
2014-04-28 22:40:56 366 (DEBUG): 
2014-04-28 22:40:56 366 (DEBUG): ftpserver has failed, please contact the sysadmin.
2014-04-28 22:40:56 366 (DEBUG): Enabling pure-ftpd in init system
2014-04-28 22:40:56 366 (DEBUG): 
2014-04-28 22:40:56 366 (DEBUG): Enabling chksrvd monitoring
2014-04-28 22:40:56 366 (DEBUG): 
2014-04-28 22:40:56 366 (DEBUG): FTP server conversion complete
2014-04-28 22:40:56 366 (DEBUG): - ssystem [END]
2014-04-28 22:40:56 372 ( INFO): Setting up name server to 'bind'
2014-04-28 22:40:56 380 ( INFO): Saving /etc/named.conf, and rebuild with cPanel defaults
2014-04-28 22:40:56 381 (DEBUG): - ssystem [BEGIN]: /usr/local/cpanel/scripts/rebuilddnsconfig
2014-04-28 22:40:56 381 (DEBUG): ./
2014-04-28 22:40:56 381 (DEBUG): ./localdomain.zone
2014-04-28 22:40:56 381 (DEBUG): ./localhost.zone
2014-04-28 22:40:56 381 (DEBUG): ./named.broadcast
2014-04-28 22:40:56 381 (DEBUG): ./named.zero
2014-04-28 22:40:56 381 (DEBUG): ./named.local
2014-04-28 22:40:56 381 (DEBUG): ./named.ip6.local
2014-04-28 22:53:25 381 (DEBUG): Named could not be restarted, any obvious config errors should show up below this line. 
2014-04-28 22:53:25 381 (DEBUG): Detected empty file at /etc/rndc.conf 
2014-04-28 22:53:25 381 (DEBUG): Creating rndc.conf
2014-04-28 22:53:25 381 (DEBUG): Creating /etc/rndc.key
2014-04-28 22:53:25 381 (DEBUG): Including rndc key file to named.conf
2014-04-28 22:53:25 381 (DEBUG): Adding controls clause
2014-04-28 22:53:25 381 (DEBUG): Restarting named
I followed this thread http://forums.cpanel.net/f34/named-wont-start-284821.html#post1191151 and I can see 953 port is open but I keep getting this error, I can dig ,y hostname properly, my /etc/resolv.conf also have google dns I followed all the threads and solution but nothing happening.

I also created support ticket with Id : 4879065

Please help because I am loosing my sleep.
 

venomdog

Member
Apr 9, 2014
7
0
1
cPanel Access Level
Root Administrator
These are more logs of my test :

Code:
[[email protected] ~]# netstat -tplanu|grep :953|grep LIST
tcp        0      0 127.0.0.1:953               0.0.0.0:*                   LISTEN      1703/named          
[[email protected] ~]# rndc reload
WARNING: key file (/etc/rndc.key) exists, but using default configuration file (/etc/rndc.conf)
rndc: connect failed: 127.0.0.1#953: timed out
[[email protected] ~]# cat /etc/rndc.conf 
# Start of rndc.conf
key "rndc-key" {
	algorithm hmac-md5;
	secret "IjsxBoa3yDJxoAqM1CsohA==";
};

options {
	default-key "rndc-key";
	default-server 127.0.0.1;
	default-port 953;
};
# End of rndc.conf

# Use with the following in named.conf, adjusting the allow list as needed:
# key "rndc-key" {
# 	algorithm hmac-md5;
# 	secret "IjsxBoa3yDJxoAqM1CsohA==";
# };
# 
# controls {
# 	inet 127.0.0.1 port 953
# 		allow { 127.0.0.1; } keys { "rndc-key"; };
# };
# End of named.conf
[[email protected] ~]# netstat -tanpu
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
tcp        0      0 0.0.0.0:3306                0.0.0.0:*                   LISTEN      734/mysqld          
tcp        0      0 0.0.0.0:587                 0.0.0.0:*                   LISTEN      778/exim            
tcp        0      0 127.0.0.1:783               0.0.0.0:*                   LISTEN      801/spamd.pid --max 
tcp        0      0 0.0.0.0:465                 0.0.0.0:*                   LISTEN      778/exim            
tcp        0      0 23.226.137.31:53            0.0.0.0:*                   LISTEN      1703/named          
tcp        0      0 23.226.137.30:53            0.0.0.0:*                   LISTEN      1703/named          
tcp        0      0 127.0.0.1:53                0.0.0.0:*                   LISTEN      1703/named          
tcp        0      0 0.0.0.0:21                  0.0.0.0:*                   LISTEN      811/pure-ftpd (SERV 
tcp        0      0 0.0.0.0:22                  0.0.0.0:*                   LISTEN      614/sshd            
tcp        0      0 127.0.0.1:953               0.0.0.0:*                   LISTEN      1703/named          
tcp        0      0 0.0.0.0:25                  0.0.0.0:*                   LISTEN      778/exim            
tcp        0     48 23.226.137.30:22            122.177.180.116:11261       ESTABLISHED 1474/sshd           
tcp        0    256 23.226.137.30:22            122.177.180.116:11365       ESTABLISHED 1788/sshd           
tcp        0    272 23.226.137.30:22            122.177.180.116:11366       ESTABLISHED 1789/sshd           
tcp        0      0 23.226.137.30:22            122.177.180.116:29448       ESTABLISHED 948/sshd            
tcp        0      0 23.226.137.30:22            122.177.180.116:29380       ESTABLISHED 879/sshd            
tcp        0      0 23.226.137.31:22            1.93.30.190:36806           TIME_WAIT   -                   
tcp        0      0 23.226.137.31:22            1.93.30.190:38552           ESTABLISHED 2031/sshd           
tcp        0      0 :::587                      :::*                        LISTEN      778/exim            
tcp        0      0 :::465                      :::*                        LISTEN      778/exim            
tcp        0      0 :::21                       :::*                        LISTEN      811/pure-ftpd (SERV 
tcp        0      0 :::22                       :::*                        LISTEN      614/sshd            
tcp        0      0 :::25                       :::*                        LISTEN      778/exim            
udp        0      0 23.226.137.31:53            0.0.0.0:*                               1703/named          
udp        0      0 23.226.137.30:53            0.0.0.0:*                               1703/named          
udp        0      0 127.0.0.1:53                0.0.0.0:*                               1703/named          
[[email protected] ~]# ps -ef | grep named
named     1703     1  0 04:46 ?        00:00:00 /usr/sbin/named -u named
root      2055  1519  0 05:14 pts/1    00:00:00 grep named
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

Per the support ticket, the issue was addressed by using a default instance of the /etc/sysconfig/named file.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
I am happy to see you were able to resolve the issue. Thank you for updating us with the outcome.