The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel Installation issue

Discussion in 'General Discussion' started by Trent Watts, Sep 26, 2015.

  1. Trent Watts

    Trent Watts Registered

    Joined:
    Sep 26, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bakersfield,CA
    cPanel Access Level:
    Root Administrator
    OS: Centos 7

    Code:
    [root@vps home]# sh latest
    Verifying archive integrity... All good.
    Uncompressing Cpanel & WHM Installer.....
            ____                  _
        ___|  _ \ __ _ _ __   ___| |
       / __| |_) / _` | '_ \ / _ \ |
      | (__|  __/ (_| | | | |  __/ |
       \___|_|   \__,_|_| |_|\___|_|
    
      Installer Version v00048 r70d81bbf6055006ac2aeba51231cc1b74b7b5c65
    
    Beginning main installation.
    2015-09-26 15:17:45  581 ( INFO): cPanel & WHM installation started at: Sat Sep                                                                                                                      26 15:17:45 2015!
    2015-09-26 15:17:45  582 ( INFO): This installation will require 20-50 minutes,                                                                                                                      depending on your hardware.
    2015-09-26 15:17:45  583 ( INFO): Now is the time to go get another cup of coffe                                                                                                                     e/jolt.
    2015-09-26 15:17:45  584 ( INFO): The install will log to the /var/log/cpanel-in                                                                                                                     stall.log file.
    2015-09-26 15:17:45  585 ( INFO):
    2015-09-26 15:17:45  586 ( INFO): Beginning Installation v3...
    2015-09-26 15:17:45  391 ( INFO): CentOS 7 (Linux) detected!
    2015-09-26 15:17:45  407 ( INFO): Checking RAM now...
    2015-09-26 15:17:45  466 ( INFO): Validating that the system hostname ('vps.hype                                                                                                                     rionservices.info') is a FQDN...
    2015-09-26 15:17:45 1128 ( WARN): Attempting to install the critical 'bzip2' pac                                                                                                                     kage for the installer...
    2015-09-26 15:17:45 1130 (DEBUG):   - ssystem [BEGIN]: yum -y install bzip2
    2015-09-26 15:17:45 1130 (DEBUG):     Loaded plugins: fastestmirror
    2015-09-26 15:17:45 1130 (DEBUG):     Loading mirror speeds from cached hostfile
    2015-09-26 15:17:45 1130 (DEBUG):     Resolving Dependencies
    2015-09-26 15:17:45 1130 (DEBUG):     --> Running transaction check
    2015-09-26 15:17:45 1130 (DEBUG):     ---> Package bzip2.x86_64 0:1.0.6-12.el7 w                                                                                                                     ill be installed
    2015-09-26 15:17:47 1130 (DEBUG):     --> Finished Dependency Resolution
    2015-09-26 15:17:47 1130 (DEBUG):
    2015-09-26 15:17:47 1130 (DEBUG):     Dependencies Resolved
    2015-09-26 15:17:47 1130 (DEBUG):
    2015-09-26 15:17:47 1130 (DEBUG):     ==========================================                                                                                                                     ======================================
    2015-09-26 15:17:47 1130 (DEBUG):      Package         Arch             Version                                                                                                                                       Repository      Size
    2015-09-26 15:17:47 1130 (DEBUG):     ==========================================                                                                                                                     ======================================
    2015-09-26 15:17:47 1130 (DEBUG):     Installing:
    2015-09-26 15:17:47 1130 (DEBUG):      bzip2           x86_64           1.0.6-12                                                                                                                     .el7             base            52 k
    2015-09-26 15:17:47 1130 (DEBUG):
    2015-09-26 15:17:47 1130 (DEBUG):     Transaction Summary
    2015-09-26 15:17:47 1130 (DEBUG):     ==========================================                                                                                                                     ======================================
    2015-09-26 15:17:47 1130 (DEBUG):     Install  1 Package
    2015-09-26 15:17:47 1130 (DEBUG):
    2015-09-26 15:17:47 1130 (DEBUG):     Total download size: 52 k
    2015-09-26 15:17:47 1130 (DEBUG):     Installed size: 86 k
    2015-09-26 15:17:47 1130 (DEBUG):     Downloading packages:
    2015-09-26 15:17:48 1130 (DEBUG):     http://mirrors.service.networklayer.com/ce                                                                                                                     ntos/7/os/x86_64/Packages/bzip2-1.0.6-12.el7.x86_64.rpm: [Errno 14] curl#6 - "Co                                                                                                                     uld not resolve host: mirrors.service.networklayer.com; Unknown error"
    2015-09-26 15:17:48 1130 (DEBUG):     Trying other mirror.
    2015-09-26 15:17:48 1130 (DEBUG):
    2015-09-26 15:17:48 1130 (DEBUG):
    2015-09-26 15:17:48 1130 (DEBUG):     Error downloading packages:
    2015-09-26 15:17:48 1130 (DEBUG):       bzip2-1.0.6-12.el7.x86_64: [Errno 256] N                                                                                                                     o more mirrors to try.
    2015-09-26 15:17:48 1130 (DEBUG):
    2015-09-26 15:17:48 1130 (ERROR):   - ssystem [EXIT_CODE] 'yum' exited with 1 (ignored)
    2015-09-26 15:17:48 1130 (DEBUG):   - ssystem [END]
    2015-09-26 15:17:48 1128 ( WARN): Attempting to install the critical 'rdate' package for the installer...
    2015-09-26 15:17:48 1130 (DEBUG):   - ssystem [BEGIN]: yum -y install rdate
    2015-09-26 15:17:48 1130 (DEBUG):     Loaded plugins: fastestmirror
    2015-09-26 15:17:48 1130 (DEBUG):     Loading mirror speeds from cached hostfile
    2015-09-26 15:17:48 1130 (DEBUG):     Resolving Dependencies
    2015-09-26 15:17:48 1130 (DEBUG):     --> Running transaction check
    2015-09-26 15:17:48 1130 (DEBUG):     ---> Package rdate.x86_64 0:1.4-25.el7 will be installed
    2015-09-26 15:17:48 1130 (DEBUG):     --> Finished Dependency Resolution
    2015-09-26 15:17:48 1130 (DEBUG):
    2015-09-26 15:17:48 1130 (DEBUG):     Dependencies Resolved
    2015-09-26 15:17:48 1130 (DEBUG):
    2015-09-26 15:17:48 1130 (DEBUG):     ================================================================================
    2015-09-26 15:17:48 1130 (DEBUG):      Package          Arch              Version               Repository       Size
    2015-09-26 15:17:48 1130 (DEBUG):     ================================================================================
    2015-09-26 15:17:48 1130 (DEBUG):     Installing:
    2015-09-26 15:17:48 1130 (DEBUG):      rdate            x86_64            1.4-25.el7            base             19 k
    2015-09-26 15:17:48 1130 (DEBUG):
    2015-09-26 15:17:48 1130 (DEBUG):     Transaction Summary
    2015-09-26 15:17:48 1130 (DEBUG):     ================================================================================
    2015-09-26 15:17:48 1130 (DEBUG):     Install  1 Package
    2015-09-26 15:17:48 1130 (DEBUG):
    2015-09-26 15:17:48 1130 (DEBUG):     Total download size: 19 k
    2015-09-26 15:17:48 1130 (DEBUG):     Installed size: 29 k
    2015-09-26 15:17:48 1130 (DEBUG):     Downloading packages:
    2015-09-26 15:17:48 1130 (DEBUG):     http://mirrors.service.networklayer.com/centos/7/os/x86_64/Packages/rdate-1.4-25.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirrors.service.networklayer.com; Unknown error"
    2015-09-26 15:17:48 1130 (DEBUG):     Trying other mirror.
    2015-09-26 15:17:48 1130 (DEBUG):
    2015-09-26 15:17:48 1130 (DEBUG):
    2015-09-26 15:17:48 1130 (DEBUG):     Error downloading packages:
    2015-09-26 15:17:48 1130 (DEBUG):       rdate-1.4-25.el7.x86_64: [Errno 256] No more mirrors to try.
    2015-09-26 15:17:48 1130 (DEBUG):
    2015-09-26 15:17:48 1130 (ERROR):   - ssystem [EXIT_CODE] 'yum' exited with 1 (ignored)
    2015-09-26 15:17:48 1130 (DEBUG):   - ssystem [END]
    2015-09-26 15:17:48 1246 (ERROR): The system could not set the system clock because an rdate binary is missing.
    2015-09-26 15:17:48  950 ( WARN): The current system time is set to: Sat Sep 26 15:17:48 CDT 2015
    
    2015-09-26 15:17:48  951 ( WARN): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    2015-09-26 15:17:48  952 ( WARN): The installation process could not verify the system time. The utility to set time from a remote host, rdate, is not installed.
    2015-09-26 15:17:48  953 ( WARN): If your system time is incorrect by more than a few hours, source compilations will subtly fail.
    2015-09-26 15:17:48  954 ( WARN): This issue may result in an overall installation failure.
    2015-09-26 15:17:48  955 ( WARN): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    2015-09-26 15:17:48  968 ( INFO): The installation process will now set up the necessary empty cpanel directories.
    2015-09-26 15:17:48  974 (DEBUG):   mkdir /usr/local/cpanel
    2015-09-26 15:17:48  974 (DEBUG):   mkdir /usr/local/cpanel/base
    2015-09-26 15:17:48  974 (DEBUG):   mkdir /usr/local/cpanel/base/frontend
    2015-09-26 15:17:48  974 (DEBUG):   mkdir /usr/local/cpanel/base/frontend/x3
    2015-09-26 15:17:48  974 (DEBUG):   mkdir /usr/local/cpanel/base/frontend/x3mail
    2015-09-26 15:17:48  974 (DEBUG):   mkdir /usr/local/cpanel/logs
    2015-09-26 15:17:48  974 (DEBUG):   mkdir /var/cpanel
    2015-09-26 15:17:48  974 (DEBUG):   mkdir /var/cpanel/tmp
    2015-09-26 15:17:48  974 (DEBUG):   mkdir /var/cpanel/version
    2015-09-26 15:17:48  974 (DEBUG):   mkdir /var/cpanel/perl
    2015-09-26 15:17:48  988 ( INFO): The installation process will now ensure that GPG is set up properly before it imports keys.
    gpg: directory `/root/.gnupg' created
    gpg: new configuration file `/root/.gnupg/gpg.conf' created
    gpg: WARNING: options in `/root/.gnupg/gpg.conf' are not yet active during this run
    gpg: keyring `/root/.gnupg/pubring.gpg' created
    gpg: /root/.gnupg/trustdb.gpg: trustdb created
    2015-09-26 15:17:48  991 ( INFO): The installation process will now import GPG keys for yum.
    2015-09-26 15:17:48  889 (DEBUG):   Retrieving http://httpupdate.cpanel.net/cpanelsync/TIERS to the TIERS file...
    2015-09-26 15:17:48  894 (FATAL): The system could not fetch the TIERS file.
    Removing /root/installer.lock.
    
    
     
    #1 Trent Watts, Sep 26, 2015
    Last edited by a moderator: Sep 26, 2015
  2. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    275
    Likes Received:
    31
    Trophy Points:
    28
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    What happens if you try to do

    Code:
    wget http://httpupdate.cpanel.net/cpanelsync/TIERS
     
  3. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    275
    Likes Received:
    31
    Trophy Points:
    28
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Actually:

    curl#6 - "Could not resolve host: mirrors.service.networklayer.com; Unknown error"

    Are you sure your resolvers are setup?

    What happens if you do:

    Code:
    # host  mirrors.service.networklayer.com
    # host  google.com
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Yes, please review the /etc/resolv.conf file on your system and ensure you are using valid resolvers. You can try using public resolvers such as 8.8.8.8 and 8.8.4.4 to see if the issue persists.

    Thank you.
     
Loading...

Share This Page