Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Cpanel is running but not responding?

Discussion in 'General Discussion' started by Funkadelic, Jun 8, 2006.

  1. Funkadelic

    Funkadelic Well-Known Member

    Joined:
    Feb 10, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    156
    I left the server running over night, it was recently recompiled with cent from Fedora and I was transferring accounts over, I woke up to find that the server was offline. The server responded to pings but nothing else, not even ssh, then randomly about an hour ago ssh started to respond, so the first thing I do is perform a restart of cpanel and the ssl services did not work, I fixed that and cpanel is running as you can see here

    Starting eximstats: [ OK ]
    Starting cPanel services: [ OK ]
    Starting cPanel Log services: [ OK ]
    Starting pop3 services: [ OK ]
    Starting cPanel Chat services: [ OK ]
    Starting Melange Chat services: [ OK ]
    Starting cPanel ssl services: [ OK ]
    Starting mailman services: Starting Mailman's master qrunner.

    However when I try to visit cpanel it just doesn't respond and neither does apache and I have recieved emails about all the services failing on the server so I'm not too sure what to do now.
     
  2. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    655
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Canada
    Do you have any type of firewall running you can disable like APF? Locking you out of ssh sounds like a firewall issue. You can also restart the cpanel services with /etc/init.d/cpanel restart
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Funkadelic

    Funkadelic Well-Known Member

    Joined:
    Feb 10, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    156
    What I was able to do is stop the iptables and that got WHM to work but still, all the services such as httpd, ftpd, mysql still don't want to come online even though it says started ok when I start/stop the service in ssh.
     
  4. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,051
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Earth
    Try to kill the processess that are currently running for the respective services. Execute the below commands and kill the PIDs you get :-
    fuser 80/tcp
    fuser 21/tcp
    fuser 3306/tcp

    and try to start the services.

    Also check in /var/log/messages if you get any clue what exactly happended.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice