cPanel last 300 errors page blank

did-vmonroig

Well-Known Member
Feb 6, 2012
66
4
58
cPanel Access Level
Root Administrator
Hello.

After reviewing this and this threads, I've a similar problem.

Errors are being shown in /usr/local/apache/logs/error_log, with this format:

Code:
[Mon Feb 15 14:50:20.392371 2016] [fcgid:warn] [pid 786:tid 139917384414976] [client 104.194.26.204:61135] mod_fcgid: stderr: PHP Warning:  call_user_func() expects parameter 1 to be a valid callback, function 'qtranxf_default_not_available' not found or invalid function name in /home/user/public_html/wp-content/plugins/qtranslate-x/qtranslate_core.php on line 586
But there is nothing in user's cPanel last 300 error log, available in htps://server:2083/.../frontend/paper_lantern/stats/errlog.html.

This seems to happen to some users' accounts only. There are others with content in cPanel, and in error_log file, too.

Any info is welcome, of course. :)
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
Hello :)

Also, keep in mind there's a different log file for the Apache error logs. PHP errors are typically logged to the error_log file within the script's document root.

Thank you.
 

did-vmonroig

Well-Known Member
Feb 6, 2012
66
4
58
cPanel Access Level
Root Administrator
I'm sorry, but I've reviewed some threads before creating a new one, because I couldn't find an answer, including the one you kindly linked, vanessa.

For example, for one of the accounts with blank last 300 errors page, I've plenty of this line in /usr/local/apache/logs/error_log:

Code:
[Tue Feb 16 13:06:31.597700 2016] [fcgid:warn] [pid 26657:tid 140184848877312] [client 91.253.173.132:62144] mod_fcgid: stderr: PHP Warning:  preg_replace(): Compilation failed: invalid range in character class at offset 24 in /home/user/public_html_userdomain_it/classes/Tools.php on line 1150, referer: http://www.userdomain.it/126-product
/home/user/public_html_userdomain_it/.htaccess is standard PrestaShop. There are no [R=] conditions.

There is content in /home/user/public_html_userdomain_it/error_log, but it logs errors up to Feb 9th, so I think something has been misconfigured when changing to Easy Apache 4 and returning to 3.

I would appreciate any ideas.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

zye

Well-Known Member
Dec 6, 2002
123
4
168
i have a simmilar problem - on all accounts the cpanel 300 most recent error messages error log is empty - but in /etc/httpd/domlogs/ files are generated with the domain name - how to resolve this?

no .htaccess files in the customers dir
running

CLOUDLINUX 7.2 x86_64 standard
WHM 56.0 (build 13)
standard cpanel theme - x3
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
New i have a simmilar problem - on all accounts the cpanel 300 most recent error messages error log is empty - but in /etc/httpd/domlogs/ files are generated with the domain name - how to resolve this?
Hello,

Could you confirm that you are using Apache version 2.4 on this system? If so, please post the output from:

Code:
grep -i LogLevel /usr/local/apache/conf/httpd.conf
You can change the LogLevel to 'info' instead of 'warn' in the httpd.conf file and then run /usr/local/cpanel/bin/apache_conf_distiller to preserve the change. This should produce the log output you are looking for. Internal case EAL-3044 was opened to ensure LogLevel is set to "info" by default in EasyApache 4.

Thank you.
 

zye

Well-Known Member
Dec 6, 2002
123
4
168
changed in httpd.conf LogLevel to 'info' and it works

thx!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
changed in httpd.conf LogLevel to 'info' and it works

thx!
I'm happy to see the issue is now resolved. I'll update this thread once the changes stemming from case EAL-3044 are released.

Thank you.
 

zye

Well-Known Member
Dec 6, 2002
123
4
168
again my settings are overwritten and again error log was empty - please help me in changing the LogLevel to info PERMANENT

and yes last time i ran /usr/local/cpanel/bin/apache_conf_distiller
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
again my settings are overwritten and again error log was empty - please help me in changing the LogLevel to info PERMANENT

and yes last time i ran /usr/local/cpanel/bin/apache_conf_distiller
Have you tried inserting the entry using the "Pre Main Include" option within the "WHM Home » Service Configuration » Apache Configuration » Include Editor" interface?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
You can change the LogLevel to 'info' instead of 'warn' in the httpd.conf file and then run /usr/local/cpanel/bin/apache_conf_distiller to preserve the change. This should produce the log output you are looking for. Internal case EAL-3044 was opened to ensure LogLevel is set to "info" by default in EasyApache 4.
Hello,

To update, the issue is addressed in cPanel 58 per the following entry in the change log:

Implemented case CPANEL-6718: Provide Apache LogLevel Adjustment in WHM.

Administrators can now configure the "LogLevel" parameter via "WHM >> Service Configuration >> Apache Configuration >> Global Configuration":

Global Configuration - Documentation - cPanel Documentation

cPanel 58 is currently only available on the "Edge" build tier. Information about the versioning and release process is available at:

cPanel & WHM Product Versions and the Release Process

Thank you.