cPanel Login Box/Prompt (HTTP Auth Popup Window versus Cookie Auth Web-based Form)

tjmoore

Member
Jun 23, 2005
19
0
151
Hi
I've deployed another cPanel server, I've configued it and its working fine apart from when you login.

Instead of this, the drop down login box: thecorrectloginbox.png (see below)

I get this instead, the basic html login box: wrongloginbox.png (see below)


I'm sure I've checked the wrong box somewhere but I just cant find it!

Any help appreciated.
 

Attachments

tjmoore

Member
Jun 23, 2005
19
0
151
I know its not wrong but I would prefer the pop up login box, I just cant understand why its not popping up :confused:
 

tjmoore

Member
Jun 23, 2005
19
0
151
Thats what I thought it was, tried it still doesn't want to work, this is what I have in the redirection panel:

Always redirect users to the ssl/tls ports when visiting /cpanel, /webmail, etc. - Check

When visiting /cpanel or /whm or /webmail WITHOUT SSL, you can choose to redirect to: Origin Domain Name

When visiting /cpanel or /whm or /webmail with SSL, you can choose to redirect to: Origin Domain Name
 

mocollin

Member
Dec 19, 2009
8
0
51
Is this 11.25? If so check this setting under "Tweak Settings" in WHM.

"Disable Http Authentication for cPanel/WebMail/WHM Logins (forces cookie authentication.) This will help prevent certain types of XSRF attacks that rely on cached Http Auth credentials."

If it is checked, it won't use HTTP Auth for logins.
 

nyubi

Registered
Jan 15, 2010
2
0
51
how to disable pop-up in webmail login?

im a newbie on site hosting and i have a question : how to disable a pop-up on webmail login, can please someone enlight me ?

logic support @ this thread http://forums.cpanel.net/f34/how-create-webmail-login-web-page-126337.html

answer : "From WHM >> Server Configuration >> Tweak Settings >>

Disable Http Authentication for cPanel/WebMail/WHM Logins (forces cookie authentication)

'Tick' the above option .

It will Skip HTTP Authentication and pop-up window will not appear . "

but in my cpanel i dont find any server configuration :confused: or what is WHM ? :D

note: im not replying that thread because it quite old (back on oct)
 

nyubi

Registered
Jan 15, 2010
2
0
51
Emailed support guys at my hosting and they reply :

Accept my apologies, it turned out cPanel currently does not allow to remove the pop-up login window.

I'd advice you to use some mail client in order to access mail via cellphone, you can find more info regarding this matter on web.


Seem they running modified cpanel ?
 

Miraenda

Well-Known Member
Jul 28, 2004
243
5
168
Coralville, Iowa USA
cPanel Access Level
Root Administrator
The option that determines if you receive a popup box or a login page is this one in WHM > Tweak Settings area under Security there:

Disable Http Authentication for cPanel/WebMail/WHM Logins (forces cookie authentication.) This will help prevent certain types of XSRF attacks that rely on cached Http Auth credentials.

If it is checked, you will have a login page without a popup box. If it is unchecked, you will have a popup box. It is more secure to have it checked and a login page.
 

WebHostPro

Well-Known Member
PartnerNOC
Jul 28, 2002
1,725
27
328
LA, Costa RIca
cPanel Access Level
Root Administrator
Twitter
The option that determines if you receive a popup box or a login page is this one in WHM > Tweak Settings area under Security there:

Disable Http Authentication for cPanel/WebMail/WHM Logins (forces cookie authentication.) This will help prevent certain types of XSRF attacks that rely on cached Http Auth credentials.

If it is checked, you will have a login page without a popup box. If it is unchecked, you will have a popup box. It is more secure to have it checked and a login page.
Thanks, good to know. I will just disable it for all logins then.
 

delphiman

Member
Jan 4, 2007
10
0
151
Cpanel and WHM not prompting for login

I don't know what I did but now everytime I go to my WHM site or Cpanel site, it does not prompting for username and password anymore. BUT is still showing the web based login windows page

Can you show me how to get my prompting back?
 

Infopro

Well-Known Member
May 20, 2003
17,112
514
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
You might try this:
WHM > Server Configuration > Tweak Settings > Redirection section.

Always redirect users to the ssl/tls ports when visiting /cpanel, /webmail, etc. checked.

When visiting /cpanel or /whm or /webmail WITHOUT SSL, you can choose to redirect to: Hostname.

When visiting /cpanel or /whm or /webmail with SSL, you can choose to redirect to: SSL Cerificate Name.

And save it.


If you don't have access to these settings you'll need to speak to your host.
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
I don't know what I did but now everytime I go to my WHM site or Cpanel site, it does not prompting for username and password anymore. BUT is still showing the web based login windows page

Can you show me how to get my prompting back?
If the pop-up login prompt is not shown it sounds like HTTP authentication may be disabled; if it is disabled this means that cookie authentication will be used with a web-based login form.

The authentication method may be toggled using WHM via the following menu paths:

In cPanel version 11.25.1:
WHM: Main >> Server Configuration >> Tweak Settings >> Security
  • Enable HTTP Authentication [?] Enable HTTP Authentication for cPanel/WebMail/WHM Logins. This risks certain types of XSRF attacks that rely on cached HTTP Auth credentials. Disabling forces cookie authentication.

In cPanel version 11.25.0:
WHM: Main >> Server Configuration >> Tweak Settings >> Security
  • Disable HTTP Authentication for cPanel/WebMail/WHM Logins (forces cookie authentication.) This will help prevent certain types of XSRF attacks that rely on cached HTTP Auth credentials.
 
Last edited:

Nu11

Registered
Jul 15, 2010
2
0
51
www.domain.tld/cpanel and all other users no popup

Hi,

www.domain.tld/cpanel

for some reason it isn't loading popup, its going directly to login page

do you know why its doing this?
 
Last edited by a moderator: