The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel login when using whmreq

Discussion in 'General Discussion' started by Phil1019, Jul 28, 2006.

  1. Phil1019

    Phil1019 Registered

    Joined:
    Jul 10, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hey,

    I am using cPanel's Accounting functions to automatically create accounts, suspend them etc.

    It has worked perfectly. However I've just come accross a problem.

    I can't upgrade accounts (packages), even though this function is included in accounting.php.inc.

    Every other function works fine. But when I try to use upacct() I get a cpanel login form.

    I cant see why this happens. At first I thought it had something to do with the upgrade form using the POST method. But I've ruled this out by being able to upgrade an account using just my browser and GET arguments.

    I've tried running CURL to the WHM page (http://localhost:2086/scripts2/upacct?user={user}&pkg={pkg}) but that doesn't work either. I'm using the correct access key (as I said before, I can use the other functions fine) so that's not the problem. Everything is correct.

    Does anyone know how I can resolve this?

    I also tried making my own edit detail function (for editing a domain or username), but the same problem (login page) occurs.
     
Loading...

Share This Page