The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel mail/hard link issue

Discussion in 'E-mail Discussions' started by Homie, Aug 28, 2004.

  1. Homie

    Homie Member

    Joined:
    Jul 22, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    When creating a new email account through cPanel, cPanel creates two seperate directories: one under /home/<user>/mail/<mailbox-username> and the other under /home<user>/mail/<domain>/<mailbox-username>.

    Now, from what it appears, both inbox use the same inode, which means that one of them is a hard link, my guess is that it's under /home/<user>/mail.

    Looks like the lots of inbox hard links are broken on my machine, which means that old email just sits there, counted against my customers quota.

    Anyone knows a quick fix besides typing manually ln blah blah one thousand times, or writing a script from scratch?

    P.S. /scripts/mailperm didn't work.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  3. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Added my voice to the report :(
     
  5. Homie

    Homie Member

    Joined:
    Jul 22, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I'm not going to file in a ticket if you already have, no pointing in bugging them :) So, if you don't mind, keep us updated as to what is the reply from cPanel support.
     
Loading...

Share This Page