The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel Main Accounts Cannot Receive Email

Discussion in 'E-mail Discussions' started by wantmaker@spider, Sep 21, 2005.

  1. wantmaker@spider

    Joined:
    Oct 27, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Greetings...

    I've got an issue where any Cpanel account setup from the WHM cannot receive email. Any account setup inside that account thereafter using the Mail Account Management interface works fine - but not the main account.

    I've seen this problem floating around the net, with most people getting lost trying to blame it on SpamAssasin only to find out it is not enabled. One try was to rename the account after it was setup, but that didn't work either.

    The mail is returned with this error:

    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 9): 550-"The recipient cannot be verified. Please check all recipients of this 550 message to verify they are valid."

    This particular report was that the problem started right after a failed account setup (WHM user tried to use a nine character username). I can't make the connection, but the problem is real. I've checked everything I can think of and would like to try everything you can think of too if I can just get it resolved.

    Anyone else had this? Get it fixed?

    Thanks in advance.
     
    #1 wantmaker@spider, Sep 21, 2005
    Last edited: Sep 21, 2005
  2. wantmaker@spider

    Joined:
    Oct 27, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    This IS a bug!

    After I kept searching with different terms, I came up with this article wherein Andrew87 has discovered the solution:

    DON'T SET DEFAULT ADDRESS TO FAIL IF YOU WANT THE MAIN ACCOUNT TO GET MAIL!!!

    Please let me know when this is fixed, as the default address is a SPAM magnet and I would prefer to "fail" it.

    Regards
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It's not a bug, it's a feature ;). It's been like this in cPanel for years and is a consequence of how cPanel use virtual accounts with exim. It's something you simply need to cater for.
     
  4. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    I just noticed this also, The user was using the main account to catch reject messages from his mailing program. Now emails hang in queue and will not deliver to the user's inbox.

    I did a test and created another email "email@domain.com" even though the "email" address matched the username. The email delivered from the queue but put it in /home/username/mail/domain.com/username/new folder.

    I've been using :fail: forever without this problem. It has occurred since the maildir conversion.

    Is there anything I can do to correct this?
     
  5. Secret Agent

    Secret Agent Guest

    Same problem here.

    Your message cannot be delivered to the following recipients:

    Recipient address: willians@client.com
    Reason: Remote SMTP server has rejected address
    Diagnostic code: smtp;550-"The recipient cannot be verified. Please check all recipients of this message to verify they are valid."
    Remote system: dns;client.com (TCP|xxx.206.4.200|30777|xxx.xxx.65.178|25) (server.host.com ESMTP Exim 4.52 #1 Wed, 10 May 2006 11:43:28 -0500 )


    2006-05-10 11:46:35 H=(mta10.srv.hcvlny.cv.net) [xxx.206.4.205] F=<sales@host.com> rejected RCPT <willians@client.com>: No Such User Here


    The client's main account username cannot receive mail, it is set to :fail: but has worked for months. Spam Assassin is off, box trapper disabled, other emails on same domain work fine on :fail:
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    As this thread already states. That's how it has always been. If you set the default address to :fail: you have to create a virtual user for the unix account and use that instead.
     
Loading...

Share This Page