SOLVED cPanel mirror doesn't work

jmginer

Well-Known Member
Jul 26, 2006
159
6
168
Alicante
cPanel Access Level
Root Administrator
Code:
[[email protected] ~]# yum clean all
6 files removed
[[email protected] ~]# yum update
EA4 ( EasyApache 4 )                             18 kB/s | 4.9 MB     04:37
cPanel Addons Production Feed                   114  B/s | 226  B     00:01
Error: Failed to download metadata for repo 'cpanel-addons-production-feed': Cannot prepare internal mirrorlist: Status code: 404 for http://httpupdate.cpanel.net/cPAddons-c-x86_64-mirrorlist (IP: 184.94.196.94)
[[email protected] ~]#
Seems the issue only happens on AlmaLinux 8 servers.
CentOS 7 based servers are working fine.
 
Last edited:

RevivalTech

Member
May 6, 2020
14
2
3
United States
cPanel Access Level
Root Administrator
So it seems I've run into a similar version, but am confused why this hasn't been fixed yet. Little help here?

Running yum search breaks and outputs
$ yum info centos-release
cPanel Addons Production Feed 1.4 kB/s | 250 B 00:00
Error: Failed to download metadata for repo 'cpanel-addons-production-feed': Cannot prepare internal mirrorlist: Status code: 404 for http://httpupdate.cpanel.net/cPAddons-c$cp_centos_major_version-x86_64-mirrorlist (IP: 184.94.196.97)

Not much on this, so I landed here. Quickly tried the fix on linked page, to no avail.
echo "fastestmirror=True" >> /etc/yum.repos.d/EA4.repo

Then I pay attention better, and notice it's not same file and what not.
I'm on cloudlinux 8 converted from fresh alma8 isntall. and get this for repos
$ ll /etc/yum.repos.d/
MariaDB105.repo cl-mysql.repo cpanel-plugins.repo
almalinux-appstream.repo cloudlinux-compat.repo epel-modular.repo
almalinux-baseos.repo cloudlinux-ea4-experimental.repo epel-testing-modular.repo
almalinux-devel.repo cloudlinux-ea4-rollout.repo epel-testing.repo
almalinux-extras.repo cloudlinux-ea4-testing.repo epel.repo
almalinux-ha.repo cloudlinux-ea4.repo imunify-rollout.repo
almalinux-powertools.repo cloudlinux-imunify360.repo imunify360-testing.repo
almalinux-resilientstorage.repo cloudlinux-rollout.repo imunify360.repo
cPAddons.repo cloudlinux.repo wp-toolkit-cpanel.repo

Sooooo, is cloudlinux-ea4.repo my equivalent here?
if yes, add fastestmirror line?

Next, I'm inspecting the url better, and notice my error is a centos url. Look that up, and oh yea duh, I keep searching for centos documentation buts it's actually EOL smh lol. So here it's more current and literally EOL url right? Sooooo, delete the repo file? What's the cPaddon replacement for almalinux 8 LSWS setup?
No delete, update URL? Can't find recommended alma8 cpaddons link... Any ideas?

Also, if we do fix, should made into a engineer ticket and address at initialization of WHM install yea?

Much appreciated for the help in advance!


UPDATE:
AH HAH!

sudo sed -i -e '/mirrorlist=http:\/\/mirrorlist.centos.org\/?release=$releasever&arch=$basearch&repo=/ s/^#*/#/' -e '/baseurl=http:\/\/mirror.centos.org\/$contentdir\/$releasever\// s/^#*/#/' -e '/^\[baseos\]/a baseurl=https://mirror.rackspace.com/centos-vault/8.5.2111/BaseOS/$basearch/os' /etc/yum.repos.d/almalinux-baseos.repo


Key part I haven't seen anywhere looking to fix this, that's "new" specific to new "on the bleeding edge install" lol: almalinux-baseos.repo

I think? haha. Came across this page,
" you might need to update the mirrors first
if your root you can exclude the sudo part for each one
so you can copy and paste starting with sed

example: copy and paste in terminal one by one and enter after each one
so
sed -i -e '/mirrorlist=http:\/\/mirrorlist.centos.org\/?release=$releasever&arch=$basearch&repo=/ s/^#*/#/' -e '/baseurl=http:\/\/mirror.centos.org\/$contentdir\/$releasever\// s/^#*/#/' -e '/^\[baseos\]/a baseurl=https://mirror.rackspace.com/centos-vault/8.5.2111/BaseOS/$basearch/os' /etc/yum.repos.d/CentOS-Linux-BaseOS.repo
then click enter.
then the next and so on.

then run dnf update -y
then reboot "

So, seems to work now!
Since it's a cpaddon mirror,def should be in some WHM initialization or ongoing double check script type thing, wouldn't ya think?
Hopefully helps peeps in the future!
 
Last edited:
  • Like
Reactions: cPRex