The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED cPanel Monitoring failures without reason

Discussion in 'General Discussion' started by Rodrigo Gomes, Mar 15, 2017.

Tags:
  1. Rodrigo Gomes

    Rodrigo Gomes Well-Known Member

    Joined:
    Apr 6, 2016
    Messages:
    82
    Likes Received:
    21
    Trophy Points:
    8
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    I often get a "cPanel Monitoring" alert of two custom services I've installed has failed.
    But I do not see any error in the message.
    And it is unlikely that two distinct services (varnish and nginx) will not function properly at the same time. **(apache too sometimes)**

    screencapture-mail-google-mail-u-0-1489610092847.png screencapture-mail-google-mail-u-0-1489610141048.png


    Five minutes later I get the alert that the service has been restored successfully.

    These failures happen on average every week.
    Before setting up the nginx and varnish services under "cPanel Monitoring" I've never had these problems. Varnish and Nginx have always been very stable, with long periods of uptime.

    Custom chkserv.d files:
    Code:
    /etc/chkserv.d/varnish
    service[varnish]=x,x,x,service varnish restart,varnishd,varnish
    Code:
    /etc/chkserv.d/varnish_ssl
    service[varnish_ssl]=x,x,x,service nginx restart,nginx,root
    All logs I found about Varnish and Nginx:
    Code:
    Mar 15 01:35:49 server systemd: Starting The nginx HTTP and reverse proxy server...
    Mar 15 01:35:49 server systemd: Starting Varnish Cache, a high-performance HTTP accelerator...
    Mar 15 01:35:49 server nginx: nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
    Mar 15 01:35:49 server nginx: nginx: configuration file /etc/nginx/nginx.conf test is successful
    Mar 15 01:35:49 server systemd: Started The nginx HTTP and reverse proxy server.
    Mar 15 01:35:50 server systemd: Started Varnish Cache, a high-performance HTTP accelerator.
    I did not find any errors in the logs,
    It seems that chkserv just restarted the services.

    What could be happening?
    I explored all the possibilities I know to debug this error, but I did not get much information.
     
    #1 Rodrigo Gomes, Mar 15, 2017
    Last edited: Mar 15, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,995
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Rodrigo Gomes likes this.
  3. Rodrigo Gomes

    Rodrigo Gomes Well-Known Member

    Joined:
    Apr 6, 2016
    Messages:
    82
    Likes Received:
    21
    Trophy Points:
    8
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    That's right!!

    I am relieved to know that the problem has now been resolved.

    Thank you!
     
    cPanelMichael likes this.
Loading...

Share This Page