The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel nameserver setup

Discussion in 'Bind / DNS / Nameserver Issues' started by Super Monkey, May 15, 2006.

  1. Super Monkey

    Super Monkey Registered

    Joined:
    May 15, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    First and foremost, I'm not very savvy with this stuff at all, so I apologise if this problem sounds incredibly dumb. Second, this is more a general setup problem on my behalf rather than a issue with cPanel itself, so I'm not expecting/demanding any support - I just didn't know where else would be best to ask.

    Here's the issue: I rent a managed dedicated server for my website. My host recently changed datacentres, and the nameserver IPs were changed. Once I was given the new IPs, I contacted my domain registrar and asked them to update the nameserver IPs to the new ones 216.183.51.135 and 216.183.51.136 (for ns1 and ns2 respectively). Everything seemed to go smooth.

    The problem I'm having appears (!) to be in the setup of cPanel. DNS Report is showing the nameserver IPs as the old ones, 64.193.62.146 and 64.193.62.147:
    http://www.dnsreport.com/tools/dnsreport.ch?domain=tokyomonsters.com

    To be honest, I really don't know much about anything, so here's what I see. Hopefully someone who actually knows this stuff will be able to see out the problem...

    The assigned Nameserver IPs still have the old IPs listed, and I can't delete them (receive an error "Sorry, the nameserver ip 64.193.62.14X cannot be removing since it is still registered with an ICANN register."). The two new IPs are both listed as ns1, which is obviously incorrect too:

    [​IMG]


    All the DNS Zones for the site have been updated to the new IPs:

    [​IMG]


    Main Shared Virtual Host IP has been updated:

    [​IMG]


    When I check IP Usage, localhost.localdomain, server.onehostnation.com and server.tokyomonsters.com are all still using the old IP 64.193.62.146, when they should be using 216.183.51.135:

    [​IMG]


    The old IP 64.193.62.146 is still appearing in the IP address list, but can't be removed:

    [​IMG]


    When trying to assign the new IPs to the nameservers, I'm simply told it already has the old Ips assigned "Sorry, the nameserver ns1.tokyomonsters.com already has the ip 64.193.62.146 assigned to it.":

    [​IMG]


    I'm probably doing something incredibly dumb, but again, I don't really know what I'm doing anyway. With the server move and nameserver problems, my sites have been offline for almost 2 weeks, so it's getting a little annoying now. Any help would be greatly appreciated!
     
  2. Super Monkey

    Super Monkey Registered

    Joined:
    May 15, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Some slight progress. I've managed to edit some stuff via SSH.

    In /etc/wwwacct.conf I edited it the nameserver section to:
    NS ns1.tokyomonsters.com
    NS2 ns2.tokyomonsters.com

    In /etc/wwwacct.conf I changed it to:

    domain tokyomonsters.com
    search tokyomonsters.com
    nameserver 216.183.51.135
    nameserver 216.183.51.136
    nameserver 127.0.0.1

    And finally in /etc/nameserverips I removed the screwed up NS listings (seen HERE) and changed it to:

    216.183.51.135=ns1.tokyomonsters.com
    216.183.51.136=ns2.tokyomonsters.com



    Buuuut, now when I got to Networking Setup > Nameserver IPs in cPanel, it automatically adds the old un-removable 64.193.62.146 NS back in (at least it hasn't effected the two new ones):
    [​IMG]

    The changes have visibly been made back in the /etc/nameserverips file again:
    [​IMG]



    Also in cPanel's Server Configuration > Basic cPanel/WHM Setup, I'm still receiving the "Sorry, the nameserver ns1.tokyomonsters.com already has the ip 64.193.62.146 assigned to it." message:
    [​IMG]


    Are there any other files I should have edited in SSH? Big thanks again for any help you can offer!

    Best,
    Jim B.
     
    #2 Super Monkey, May 15, 2006
    Last edited: May 15, 2006
  3. indu

    indu Registered

    Joined:
    Mar 26, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Try enabling Allow Sharing Nameserver Ips & Disable whois lookups for the nameserver ip manager under System category in Tweak Settings of your whm.
     
  4. mctDarren

    mctDarren Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    664
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    New Jersey
    cPanel Access Level:
    Root Administrator
    This thread is four months old... ?? What inspired a reply now? :D
     
  5. Secmas

    Secmas Well-Known Member

    Joined:
    Feb 18, 2005
    Messages:
    321
    Likes Received:
    0
    Trophy Points:
    16
    Thankyou Indu,
    your answer even that is four months old, has helped me today.

    Regards.
     
Loading...

Share This Page