The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel not adding folder.

Discussion in 'General Discussion' started by simonpeterong, Oct 16, 2007.

  1. simonpeterong

    simonpeterong Registered

    Joined:
    Oct 16, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I am using cPanel 11, the first time I got my web hosting a month ago, I successfully added a subdomain.

    Last week I did add another subdomain, but this time, it didn't work, meaning cPanel didn't create a folder for my subdomain as it was supposed to. I asked my web host about it and they said that they had an update of some sort and that might had something to do with this problem, but they are not sure.

    With a recent update, will that affect the function of the cPanel with regards to me creating a new subdomain and the cPanel automatically creating a folder for my subdomain?
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Are you using the X or X3 theme? If you are still on the X theme, I strongly recommend you tell your hosting provider to move you to the X3 theme. It will give you more flexibility with regards to creating subdomains, addon domains etc.
     
  3. simonpeterong

    simonpeterong Registered

    Joined:
    Oct 16, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Originally, I have an X theme, there was an option on my cPanel to use RVSkin. I did change to RVSkin, I can create subdomains properly, but when I type the url subdomain.mydomain.com, the URL will revert me to mydomain.com/subdomain/ not the usual subdomain.mydomain.com :confused:
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    There is a current incompatibility between a certain Tweak Setting and the X theme (yes, I realize you are using RVSkin). If your Web Host has enabled the Tweak Setting "Prevent users from creating subdomains outside of their public_html directory", creating a Sub Domain in the X theme successfully creates the Sub Domain, but the directory in public_html is not created.

    The other problem detailed in your followup post could be a redirect issue. Your Web Host's support team should be able to assist you with that.
     
Loading...

Share This Page