The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CPanel on FreeBSD 5.4 on x64 machines

Discussion in 'General Discussion' started by yaax, May 23, 2005.

  1. yaax

    yaax Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    I am planning to purchase new server as dual opteron and install there latest release of FreeBSD 5.4
    Since Cpanel not listed FreeBSD 5.4 in the list of supported versions I am not sure it will work on this OS....
    Also for x64 machines even FreeBSD 5.3 is not supported by cpanel...
    Can anyone tell something about any problems with Cpanel and FreeBSD 5.3 and 5.4 on x64 machines?
     
  2. yaax

    yaax Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Anyone?....
     
  3. Yaza

    Yaza Member

    Joined:
    May 23, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I am in the same position (have a dual opteron server and want to use the latest freebsd AMD64 distro) and would also like to hear from any FreeBSD 5.4 users.
     
  4. masood

    masood Well-Known Member

    Joined:
    Jun 14, 2002
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
  5. dotmn

    dotmn Member

    Joined:
    Oct 15, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    FreeBSD now shows up as being supported for v5.4 x64. Has anyone ran cPanel on it yet?
     
  6. Scott Greczkows

    Scott Greczkows Well-Known Member

    Joined:
    Feb 5, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    I am running it with FreeBSD 6.1 x64 with no issues.
     
  7. Imago

    Imago Active Member

    Joined:
    Feb 21, 2004
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Is there a way to upgrade from 5.4 @32 to 6.1 @64. I am testing an ovh.com 64-bit server and there is no way, given the reinstallation options, to properly install cPanel.

    And the options are Suse 10.0 @32, FreeBSD 5.4 @32, and Fedora 4 only bundled with Plesk.
     
  8. Imago

    Imago Active Member

    Joined:
    Feb 21, 2004
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    cPanel has installed @ FreeBSD 5.4 i386 (the machine is 686_64) but there are many little bugs. Some of them disappeared after updating to C75. Still the php4 cannot be ungraded to php5.
     
  9. Imago

    Imago Active Member

    Joined:
    Feb 21, 2004
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Update

    MySql40-server, scripts, client
    make deinstall

    mysql41-server, scripts, client
    make install

    then update Apache and select any php5 option.

    cPanel do not officially support FreeBSD x86_64, at least there is no such tab in layer1

    There are also big problems with DNS and BIND config that result in making port 53 not listening.
     
  10. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    FreeBSd calls this platform amd64, and it is supported by cPanel on 5.3, 5.4, 6.0 and 6.1 (working on 5.5 for both)
     
  11. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Really?...How about adding the servers IP's to this line in the named.conf file
    and your problem is solved...;)

    listen-on { 207.99.xx.xx; 207.99.xx.xx; };
     
Loading...

Share This Page