The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel on SuSE 9.0

Discussion in 'General Discussion' started by hmmblah, Dec 14, 2004.

  1. hmmblah

    hmmblah Member

    Joined:
    Dec 14, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I've installed cPanel on a basic install of SuSE 9.0 3 times and I get the same problem every time. Apache does not load right. It always says failed when I log into cpanel, and all the apache and httpd directories do not exist on the server. I saw another thread with a similar problem, but it was on freeBSD 4.9. They said apache was not compiling right. There was no solution on this thread. Please help us out. I use cPanel for my personal webpage through my webhost, and it seems like the best option in terms of ease of use and functionality.

    I'm testing cPanel out because we want to migrate our webservers to linux and cPanel looked like the best option. I need to have a demo up to show my boss so it can be approved for purchase.

    Thanks.
     
  2. hmmblah

    hmmblah Member

    Joined:
    Dec 14, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    This is what I get when I try to build apache from within cPanel:

    Building Apache Config.....Done
    Downloading and compiling apache+modules....

    Verifying archive integrity... All good.
    Uncompressing buildapache.......................................................................................................................
    Verifying compiler and libs....Updating /scripts...Done
    Verifying installation....Done
    Done
    ********************************
    This is buildapache version 9.9.8s
    ********************************
    buildapache configured from Web Host Manager
    Apache configured from Web Host Manager!
    Untarring expat...Done

    configure expat-1.95.6...(--prefix=/usr).... . . . . . . Done

    make expat-1.95.6....... . . . . . . . . . . . . . . . . . . . . . . . . Done

    make expat-1.95.6...(install).... Done

    Untarring apache....
    Suexec Standard Patch
    patching file src/support/suexec.c
    patching file src/support/suexec.h
    Suexec MailMan Patch
    patching file src/support/suexec.c
    Fileprotect Suexec Standard Patch
    patching file src/support/suexec.c
    Hunk #1 succeeded at 224 (offset -44 lines).
    Hunk #2 succeeded at 254 (offset -44 lines).
    Hunk #3 succeeded at 556 (offset -44 lines).
    HTTPS var Standard Patch
    patching file src/support/suexec.c
    Hunk #1 succeeded at 131 (offset -43 lines).

    configure apache_1.3.33...(--enable-shared=max).... . . . . . . . . Done

    patching file src/include/httpd.h
    Hunk #1 succeeded at 272 (offset -44 lines).
    Untarring modssl....
    patching file pkg.sslmod/libssl.module

    configure mod_ssl-2.8.22-1.3.33...(--with-apache=../apache_1.3.33 --with-ssl=/usr --enable-module=expires --enable-shared=expires --add-module=../mod_frontpage.c --enable-module=rewrite --enable-shared=rewrite --enable-suexec --suexec-logfile=/usr/local/apache/logs/suexec_log --suexec-caller=nobody --suexec-uidmin=100 --suexec-gidmin=100 --suexec-docroot=/ --suexec-userdir=public_html).... . . . . . . . . . . . . . Done

    configure apache_1.3.33...(--enable-module=ssl --enable-module=expires --enable-shared=expires --add-module=../mod_frontpage.c --enable-module=rewrite --enable-shared=rewrite --enable-suexec --suexec-logfile=/usr/local/apache/logs/suexec_log --suexec-caller=nobody --suexec-uidmin=100 --suexec-gidmin=100 --suexec-docroot=/ --suexec-userdir=public_html).... . . . . . . . Done

    make apache_1.3.33....... Done

    make[1]: *** [build-std] Error 2
    make: *** [build] Error 2

    make apache_1.3.33...(install).... Done

    make[2]: *** [build-std] Error 2
    make[1]: *** [build] Error 2
    make: *** [install-all] Error 2
    /etc/rc.d/init.d/httpd start: httpd could not be started
    Setting /home permissions to 0711......Done
    Setting permissions for.....nobody...cpanel...mailman......Done
    Untarring php....Done
    Applying CURL curl_formfree patch
    patching file ext/curl/curl.c
    Hunk #1 succeeded at 563 (offset 18 lines).
    Hunk #2 succeeded at 909 (offset 24 lines).

    configure php-4.3.9...(--with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --enable-ftp --enable-magic-quotes --with-mysql --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zlib).... . . . Done

    configure: error: Aborting

    make php-4.3.9...(clean).... Done

    make php-4.3.9....... Done

    make php-4.3.9...(install).... Done

    /etc/rc.d/init.d/httpd start: httpd could not be started

    configure php-4.3.9...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --enable-ftp --enable-magic-quotes --with-mysql --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

    make php-4.3.9...(clean).... Done

    make php-4.3.9....... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

    make php-4.3.9...(install).... . . . . . . . . . Done

    initfpsuexec: using apache 1.x support
    PHP version file has been updated to
    ./build all
    ./build install
    ./build install
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd could not be started

    Attempting to restart httpd

    Waiting for httpd to restart....
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    finished.





    httpd status






    httpd has failed, please contact the sysadmin.







    Build Complete
     
  3. Ramsy

    Ramsy Guest

    check you /home/cpins/installd/buildapache/build-logs to figure out what went wrong ...
    i had some troubles installing cpanel on suse as well ..
    the thing i did to resolv it was reinstall openssl as in my case there were some problems with that.
    also be sure to have cc/gcc installed.
    after getting apache to work it simply didnt run as i would like it to run.
    i tested out quite a few distro's and found that CentOS was the best.
    i'd really recommend it.
    been running on freebsd 5.x for a year now but always had troubles with linux comp and such.
    http://www.centos.org
    download all 3 cd's burn, deselect all packages and only select gcc/cc etc.
    edit your /etc/centos-yum.conf and /etc/yum.conf and exclude things like kernel* mysql*
    then perform:

    rpm --import http://mirror.caosity.org/centos-3/RPM-GPG-KEY-CentOS-3

    make a dir in /home called cpins
    wget the latest cpanelbuild
    install and all should work just perfectly without any errors
     
  4. roliboli

    roliboli Active Member

    Joined:
    Sep 3, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Switzerland
    We are using Suse 9.0 on our server in production for one year without compliance.
    In the beginning some adjustments have to be done but now it works.

    See my older thread:
    http://forums.cpanel.net/showthread.php?t=18758

    Now we are waiting for Cpanel support for Suse 9.2 for our new servers.
    Hope it will be released as soon as possible.
     
Loading...

Share This Page