The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel on virtuozzo install problems

Discussion in 'General Discussion' started by Secret Agent, Feb 2, 2006.

  1. Secret Agent

    Secret Agent Guest

    ./bootstrap: line 21: ./futexfix: No such file or directory
    cat: /boot/System.map*: No such file or directory
    Your operating system's rpm update method (yum) was not able to locate the glibc package. This is an indication of an improper setup. You must correct this error before you can proceed.


    What should be done to correct this? Yum is not installed by default on Virtuozzo vps
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    insure yum is installed example below is for centOS 3


    rpm -ivh http://mirror.centos.org/centos/3.6/os/i386/RedHat/RPMS/yum-2.0.8-1.centos.7.noarch.rpm

    rpm --import http://mirror.centos.org/centos/3.6/os/i386/RPM-GPG-KEY-CentOS-3

    and add
    glibc*

    into the exclude= in /etc/yum.conf
     
  3. Secret Agent

    Secret Agent Guest

  4. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    well you need to do what it says and resolve your dependencies installing the correct rpm's
     
    #4 dalem, Feb 2, 2006
    Last edited: Feb 2, 2006
  5. rviradia

    rviradia Well-Known Member

    Joined:
    Jul 25, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Having a similar problem on virtuozzo, but for redhat enterprise AS3, here's the error:

    Your operating system's rpm update method (up2date) was not able to locate the glibc package. This is an indication of an improper setup. You must correct this error before you can proceed.

    not sure how up2date works with RHES AS3 virtuozzo since there is none...

    ps - if running fedora on virtuozzo, this seems to do the trick without dependency complaints;

    rpm -Uvh ftp://rpmfind.net/linux/fedora/core/2/i386/os/Fedora/RPMS/yum-2.0.7-1.1.noarch.rpm
     
    #5 rviradia, Feb 7, 2006
    Last edited: Feb 7, 2006
  6. pizzaman

    pizzaman Well-Known Member
    PartnerNOC

    Joined:
    Oct 1, 2003
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    To run yum inside virtuozzo, make sure to install devel-ce3 template before installing yum.
     
    #6 pizzaman, Feb 16, 2006
    Last edited: Feb 18, 2006
Loading...

Share This Page