Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel + php-fpm: enabled but not working

Discussion in 'General Discussion' started by Diogo Barioni Abdalla, Feb 1, 2018.

Tags:
  1. Diogo Barioni Abdalla

    Joined:
    Feb 1, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ubatuba
    cPanel Access Level:
    Root Administrator
    I hope this is the right place to ask. If it inst, please direct me to right subforum.

    I have this CentOS 6.9 VPS server with cpanel and WHM, running Apache 2 with PHP 5.6

    Ive enabled PHP-FPM on WHM and it shows as active in both WHM and Cpanel (in the MultiPHP manager sections)

    I also have this on my httpd.conf:

    <IfModule proxy_fcgi_module>
    <FilesMatch \.(phtml|php[0-9]*)$>
    SetHandler proxy:unix:/opt/cpanel/ea-php56/root/usr/var/run/php-fpm/fc680a9025c37fd635d3cad33dda11786afdf8c0.sock|fcgi://domain.tld
    </FilesMatch>
    </IfModule>

    To be sure, I even copied it to the conf where Im setting my vhost.

    And PHP-FPM seems to be running, according to its logs ("NOTICE: ready to handle connections" on the php-fpm error.log)

    But when I go see phpinfo(), it still says:

    Server API CGI/FastCGI

    So what am I missing? How to debug this? Ive restarted apache and php-fpm many times, and even rebooted the server, to no avail
     
    #1 Diogo Barioni Abdalla, Feb 1, 2018
    Last edited by a moderator: Feb 1, 2018
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Are you using any custom Apache templates in the /var/cpanel/templates/apache2_4/ directory? Custom templates will end with ".local".

    Thank you.
     
  3. Diogo Barioni Abdalla

    Joined:
    Feb 1, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ubatuba
    cPanel Access Level:
    Root Administrator
    Nope. There's 4 files on that path, one .json (000-local_template_check.json) and 3 .default files
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here and we will update this thread with the outcome.

    Thank you.
     
  5. Diogo Barioni Abdalla

    Joined:
    Feb 1, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ubatuba
    cPanel Access Level:
    Root Administrator
    Sorry, but Im not finding the option to create a support ticket.

    On the page you linked there are there instructions:

    1. Log in to WHM as the root user.
    2. In the WHM Home interface, click Support.
    3. Click Create Support Ticket.
    However, on my WHM I cant seem to find the Create Support Ticket option: when I click at the support button at the WHM home, there's only 3 options (Cpanel & WHM FAQ, Support forums and Documentation)
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    It's likely your license is purchased through a third-party provider. In such cases, it's generally advised that you contact your provider for support first, and if they are unable to help you, you can open a ticket directly with us by setting up an account on the cPanel Customer Portal.

    Thank you.
     
Loading...

Share This Page