The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel pop3 login failed

Discussion in 'E-mail Discussions' started by mercnix, Apr 18, 2008.

  1. mercnix

    mercnix Registered

    Joined:
    Mar 28, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    hi all
    i have a problem with a cpanel pop3 service
    the problem is a login in pop3 .. all the mail clients on port 110 respond with a login failed.
    the problem born a few days ago and i can't find a solution

    bye
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I know a few days ago there were some issues with cppop (used only by servers still on the antiquated mbox format). I recommend running /scripts/upcp and see if that resolves the issue. If not, please submit a support ticket: http://tickets.cpanel.net/submit

    We do offer free assistance with migrating from mbox to maildir, see the interactive script /scripts/convert2maildir for details. I would recommend you do that at your earliest convenience as mbox support will be fully deprecated in version 12.
     
  3. claudio

    claudio Well-Known Member

    Joined:
    Jul 31, 2004
    Messages:
    201
    Likes Received:
    0
    Trophy Points:
    16
    pretty lame

    Hi

    this is not only annoying but pretty lame (sorry for that but it is true)

    i have a server it was constantly attacked by hackers in order to produce a pop3 flood

    cpanel disabled cppop flood protection saying that now everyone should upgrade to maildir what is not bad but will kill NEOMAIL

    so i made my own firewall to block this cppop flood because i cannot change this old server to maildir and i also have many things there old stuff that would make the use of Chirp's new firewall hard to be installed (i have many perl scripts combined with APF to block some attacks to some of my customers and i cannot disable my apf by now)

    TODAY i suffered a big attack in pop3 and caused my server to be rebooted

    guess what?????

    my /etc/cpupdate.conf is configured in all parameters to NEVER even then after this unexpected reboot my server got back online using COURIER !!!

    ok i killed courier process and tryed to manually run

    /scripts/./restartsrv_cppop and guess what???

    it tried to bind 995 port due to CPPOP_SSL.pl was just loaded alone in port 110

    If anyone of CPANEL ADMINS could at least tell me how cpanel change its functions alone i would be glad to hear would be a little respect with us, it is not the first time i complain on this issue, cpanel sometimes change it's behavious alone...

    ok to solve the issue i made

    first KILL all process running at port 110 (courier or cppop_ssl)

    then as root in the ssh windows type:

    cd /usr/local/cpanel/etc/init

    cp startcppop startcpop_bk

    pico startcppop

    now at line 19 you should comment it adding a # in the begining

    # exec $cppop_ssl;

    and after it you should place a copy of the non_ssl statment

    my $cppop = -e '/usr/local/cpanel/bin/cppop.pl' ? '/usr/local/cpanel/bin/cppop.pl' : '/usr/local/cpanel/bin/cppop';
    exec $cppop;

    see below the whole code how it looks now:


    Code:
    #!/usr/bin/perl
    
    use lib '/usr/local/cpanel';
    use strict;
    use Cpanel::Config ();
    
    system '/usr/local/cpanel/etc/init/stopcppop';
    
    my $conf_ref = Cpanel::Config::loadcpconf();
    exit if $conf_ref->{'maildir'} eq '1';
    
    my $cppop_ssl = -e '/usr/local/cpanel/bin/cppop-ssl.pl' ? '/usr/local/cpanel/bin/cppop-ssl.pl' : '/usr/local/cpanel/bin/cppop$
    my $bincheck  = `$cppop_ssl --bincheck 2>/dev/null`;
    my $ssl       = $bincheck =~ m/BinCheck\s+ok/ ? 1 : 0;
    
    exit if fork();
    
    if ($ssl) {
    #    exec $cppop_ssl;
    
      my $cppop = -e '/usr/local/cpanel/bin/cppop.pl' ? '/usr/local/cpanel/bin/cppop.pl' : '/usr/local/cpanel/bin/cppop';
        exec $cppop;
    
    }
    else {
        my $cppop = -e '/usr/local/cpanel/bin/cppop.pl' ? '/usr/local/cpanel/bin/cppop.pl' : '/usr/local/cpanel/bin/cppop';
        exec $cppop;
    }
    
    exit;
    then just run

    ./startcppop and it will work just fine...

    hope this can help some beginners

    thanks and please cpanel try to leave old stuff as it is there is no sense in messing with old servers that are quite, i cannot tell 200 users that neomail has gone and now they are imposed to use HORDE and to tell you the true horde is full of security issues nowadays...

    Claudio
     
    #3 claudio, May 5, 2008
    Last edited: May 5, 2008
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    What is your full cPanel version number?

    What does
    Code:
    grep maildir /var/cpanel/cpanel.config
    
    report?
     
  5. claudio

    claudio Well-Known Member

    Joined:
    Jul 31, 2004
    Messages:
    201
    Likes Received:
    0
    Trophy Points:
    16
    Hi

    my cpanel version

    WHM 11.15.0 cPanel 11.18.3-S21703
    CENTOS Enterprise 3.6 i686 on standard - WHM X v3.1.0

    the command reported:

    # grep maildir /var/cpanel/cpanel.config
    maildir=0

    thanks
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Thank you. If you wouldn't mind providing some more information on this matter, it would be helpful in deducing what is happening, and what needs fixed.

    If you would, please provide the contents of /etc/cpupdate.conf

    Also, in your update logs, found in /var/cpanel/updatelogs, what is occurring when the update process begins updating courier? For example, on a test machine, the logs show:

    Code:
    Updating courier...Update for courier are disabled because (Package updates [SYS
    UP]) is set to never in /etc/cpupdate.conf
    ...Done
    
     
  7. claudio

    claudio Well-Known Member

    Joined:
    Jul 31, 2004
    Messages:
    201
    Likes Received:
    0
    Trophy Points:
    16
    Hi

    in fact cpupdate.conf content is:


    COURIERUP=never
    CPANEL=MANUAL
    EXIMUP=never
    RPMUP=never
    SYSUP=never

    i thought that was Never as other servers of mine... but recently a month ago, i runned
    upcp --force to solve the horde issue

    regarding to update log


    Updating courier...Update for courier are disabled because (Package updates [SYSUP]) is set to never in /etc/cpupdate.conf
    ...Done

    forcing cppop to start as non-ssl mode solved my issue as i mentioned at my first post in this thread

    but i appreciate your help in figuring out how this tiny changes occur at my cpanel box

    Thanks
    Claudio
     
Loading...

Share This Page