The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel Problematic Installation! Need Help!

Discussion in 'Database Discussions' started by rocketxau, Oct 24, 2005.

  1. rocketxau

    rocketxau Member

    Joined:
    Oct 23, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hey Guys,

    We're new to installing cpanel - We just got a new server running Red Hat EL 4 (Update 2).
    When we install cpanel we install on a fresh install of RHEL4.

    Two days ago I installed cPanel but got a few problems:

    - chsrvd could not load up.
    - exim could not load, or compile for that matter?
    - mySQL : could not load up, something about a mysql.sock (2) error.

    Other than that, it loaded up into Gnome fine. So i thought the problems would go away if we reinstalled so...

    Today:

    We formatted the drives and re-installed RH 4.

    Thats when the problems start coming up, we installed cPanel and we get the same problems including the above. Then we restarted the machine after cPanel finished it's installation and it tells us it failed to load X Server. Funny enough, we had X-Server on it, but the thing is that it was working two days prior with x-server and gnome AND cPanel installed.

    So we took xserver off during the next installation and it DID THE SAME THING! This thread has exactly our problem..

    http://forums.cpanel.net/showthread.php?t=43299&highlight=xserver

    So what's going on? We really need to get cPanel on or else we will need to look for alternatives. All up, i believe we re-installed our linux server about 4 times, each time failing!!

    Could someone please shed some light on the other problems we're having?

    Many Thanks,
    Carl
     
    #1 rocketxau, Oct 24, 2005
    Last edited: Oct 24, 2005
  2. wms2006

    wms2006 Member

    Joined:
    Oct 23, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I am having the exact same error. I think there is a bug in the installation file. I have installed cpanel before, doing the exact same steps I am doing now and it is not working.
     
  3. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    18
    If you really wanted to run gnome you can do it. You just have to edit the runlevel in /etc/inittab to 3 and that'll allow you to run gnome desktop... and security is not a concern if you have taken the proper server/network precautions...

    Oh yeah and you have to edit xorg.conf and comment out the fontpath and the server (unix:7100) lines...
     
    #3 wills, Feb 8, 2006
    Last edited: Feb 9, 2006
  4. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Yep I am getting eximstats error and mysql sock error.

    Shame cpanel was doing good for so long, I thought they finally where on track for good. :(
     
  5. Shinichi Kato

    Shinichi Kato Well-Known Member

    Joined:
    Mar 7, 2005
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Saitama-ken,japan
    Main >> Server Configuration >> Update Config

    Automatic (STABLE tree) or Manual Updates Only (STABLE tree)

    Main >> cPanel >> Upgrade to Latest Version

    Please confirm it " latest STABLE build.".

    Click to Upgrade.

    If it is useless, let's reboot. :)

    TMS:www.totalmediastudio.ne.jp
     
  6. glilly

    glilly Member

    Joined:
    Mar 6, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    New York
    :( I'm having ths same problems. I'm not so concerned about not having the XServer, but I really need mysql. I'm getting the error message:

    Can't connect to local MySQL server through socket '/var/lib/mysql.sock' (2)

    I get this message when trying to change a user SQL password in CPanel; also, when trying to use mysqladmin as root on the server

    When I start /usr/sbin/mysqld from the command line I get the following errors:

    Can't open file: 'host.MYI". (errono: 142)
    Fatal error: Can't open privilege tables: File '/usr/share/mysql/charsets/?.conf' not found (Errcode: 2)
    Aborting

    Can someone please help me with this?

    Thanks

    ...

    I am also getting SNMP messages from SELinux about mysql. I think mysql has been thrown out of the SELinux "targeted object" control policy (policy.18). I have read some of the RH SELinux manual, but can't figure out how it works on the RHEL4 distribution. And particularily with mysql and cPanel. I can't find the mysql.fc file to make and add to the policy or any other way to stop SELinux from carping and mysql from shutting down every time it starts....
    gpl
     
    #6 glilly, Mar 6, 2006
    Last edited: Mar 7, 2006
  7. rocketxau

    rocketxau Member

    Joined:
    Oct 23, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    hey glilly,

    i'm not totally sure I remember how we fixed the problem.. but after about 10 re-installs of our server we actually thought to disable SELINUX in the installation of Red Hat.. I think cpanel just has problems with it enabled. try it and see if this works for you.

    regards
     
  8. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    If I remember the docs correct cpanel install should have disabled SELinux while installing cpanel

    But none the less always install the OS with SELinux disabled and its best to use a minimum install of the OS
     
  9. glilly

    glilly Member

    Joined:
    Mar 6, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    New York
    :eek: Thanks for the pointers...

    In order to try and narrow down the things I might be doing wrong, I installed Fedora Core 3 with SELinux turned off at the install. MySql worked right away after the install as it always does. CPanel installed great and seems to wrok perfectly including phpMyAdmin...

    So, now I've narrowed it down to RHEL4, me and MySQL .... I'll try that next...

    I'll let you know what happens...

    gpl
     
  10. glilly

    glilly Member

    Joined:
    Mar 6, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    New York
    How it turned out for me

    :D After much trial and error, and support from MySQL and RedHat, my RHEL4 system is up and running with the Released Cpanel and MySql 4.1.

    For any who's interested in exactly how I did it, here are the steps:

    1. install RHEL4 from scratch
    2. run up2date for all included packages
    2. disable SELinux in /usr/selinux/selinux.conf
    3. install CPanel according to instructions (it installs MySql 4.0 and fails to start it)
    4. Log on to the WHM and under Server Configuration "Tweek Settings" tell it to use MySQL 4.1
    5. Under WHM "Software" Update System Software and Update Server software

    Like magic, MySql 4.1 is installed and starts right up...

    ...sounds simple, but I wish I knew it a few weeks ago...

    thanks to everyone for their pointers and help.

    George Lilly
     
  11. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    hey

    I have a similar problem. mysql 4.0.25 wont work, as sooon as i update to 4.18 its fine.
    Im using Centos 4.3 , brand new install of cpanel

    try start mysql for the first time
    tail -f /var/log/mysqld.log
    Edit /etc/my.cnf and comment that variable out

    try start mysql again

    OMG.. woot... cant chnage to user.

    /scripts/mysqlup --force
    it seems fine, but does throw some errors

    tail -f /var/log/mysqld.log

    Hmm... charsets...

    mysqlup --force
    same as before :(

    still no good


    [root@bs25 mysql]# myisamchk -dvv host.MYI
    /var/lib/mysql

    When trying to start mysql it does start but It doesnt create the mysql.sock
    and doesnt create the pid file either

    so you cant access it.

    Go into WHM and update to LATEST CURRENT RELEASE
    force mysql up

    still no good.

    Go into WHM - updating to 4.1.18

    Mysql works perfectly now

    So is the installer for mysql 4.0 messd up... wonder if i should open a bugzilla for it ?

    Thanks for the help
    andy
     
  12. glilly

    glilly Member

    Joined:
    Mar 6, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    New York
    let cpanel upgrade MySql for you

    :cool: after painful experience fiddling with MySql on my own after installing CPanel, the only success I had was to "tweek settings" inside CPanel and let it do the installation of MySql. I think you're right that CPanel's 4.0 installer won't work with RHEL4 under any scenario. However, if you tell CPanel to use 4.1, it works great. I"m not sure this is a bug worth chasing, as 4.1 is really a better release of MySql anyway. I hope MySql 5.0 gets out of "leading edge" soon and we can start using it... MySql.com support is really geared up to support that, and it would give us the best combination of support options.

    gpl
     
  13. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    mysql upgrade can fail and a solution is to add a file to the charset directory.

    Do the following and see:

    I tried checking the database file with myisamchk:
    myisamchk /var/lib/mysql/mysql/host.MYI

    The error message said that mysql's programs can't find charset number 83.
    So I added one to /usr/share/mysql/charset/Index


    Add MYSET to the end of the sql/share/charsets/Index file. Assign a unique number to it.

    1. Create the file sql/share/charsets/MYSET.conf. (I use lower case: myset.conf)
    (You can use a copy of sql/share/charsets/latin1.conf as the basis for this file.)

    2. Add an entry at the bottom of the Index file so that it looks like this:

    win1250 26
    croat 27
    gbk 28
    cp1257 29
    latin5 30
    latin1_de 31
    myset 83


    service mysql start

    Thats it!

    Fixed and working.
     
  14. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16

    Yey!!.. I helped someone :))

    Glad it worked for you :).

    I had two upgrades that I needed to use this 'trick'. The upgrades were a year a part, but
    it was the same trick :)

    Glad it help you.

    -Alon.
     
  15. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    see here.. http://bugzilla.cpanel.net/show_bug.cgi?id=4049

     
Loading...

Share This Page