Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

cpanel pure-ftpd not starting up on machine boot

Discussion in 'General Discussion' started by renegadeavenger, Nov 8, 2005.

  1. renegadeavenger

    renegadeavenger Registered

    Joined:
    Jul 16, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    this is weird.. this is the first encounter of me playing with cpanel that pure-ftpd doesn't automatically startup with machine boots. Can someone help me with making it bootup on start? Or do I just have to add the line in rc.local /etc/init.d/pure-ftpd start ?

    thanks
     
  2. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    Hello,

    Go to WHM
    Main >> Service Configuration >> Service Manager and enable ftpd

    Then try :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. intel352

    intel352 Well-Known Member

    Joined:
    Nov 25, 2003
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    NC, USA
    i manage 2 servers running Centos 4 + WHM/CPanel, on one, ftpd is enabled via whm, starts up properly every time. on the other, ftpd is enabled via whm, yet did not load on start. i opened Webmin -> Bootup/Shutdown, and viewed the pure-ftpd configuration, it was not set to start at boot...

    Any ideas why this might be set properly on one server, but not another?


    EDIT: nevermind, the service started up (via WHM) and was running, but wouldnt' accept connections. i'm researching...
     
    #3 intel352, Mar 8, 2006
    Last edited: Mar 8, 2006
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    If it's not restarting at boot, just do:

    chkconfig pure-ftpd on
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. intel352

    intel352 Well-Known Member

    Joined:
    Nov 25, 2003
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    NC, USA
    I found it was started/running after the server rebooted, but it wasn't allowing any connections (as if it were down). Restarting pure-ftpd then allowed connections... Not sure why it errored like that, I'll have to find it's error log when I get a chance.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice