Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

cPanel redirecting to default page (apache_port bug)

Discussion in 'EasyApache' started by dooh, Oct 22, 2013.

  1. dooh

    dooh Registered

    Joined:
    Jul 19, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    151
    Hi there,

    As I am using different webservices in front of cPanel's apache, after updating to cPanel 11.40.0 I had issues with new accounts or new subdomains that lead me to discovering this bug.

    New cPanel version ignores apache_port when adding a new virtualhost (createacct).
    Instead of creating the virtualhost with 0.0.0.0:8000 (my modified port)
    it creates it with 0.0.0.0:80 .

    This is a BUG, please test it yourself on any cPanel 11.40.0 and change in tweak settings, apache binding port to 0.0.0.0:8000 or any other port.
    Save, create a new account, and after creating the new account check httpd.conf and see if the virtualhost is created with the new correct port or the default apache one.

    As cPanel does not have any public bug report, I am writing it here, and for anyone that has this issue, as a workaround for those who encounter this issue (not for subdomains) add this to /scripts/postwwwacct

    /scripts/rebuildhttpdconf
    service httpd restart
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    dooh likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice