The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel redirects system recently broken by cpanel update

Discussion in 'General Discussion' started by wolfy, May 19, 2008.

  1. wolfy

    wolfy Well-Known Member

    Joined:
    Jul 20, 2005
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Canada
    we had resently updated 2 machines to cpanel version 11.18.6-R24533
    since this update, cpanel will prefix the "redirect to" url (/frontend/x3/mime/redirect.html) with an extra "http://" .
    anyone else haveing this issue?


    note:all cpanel redirects in version 11.18.6-S24255 seem to work correctly.
     
  2. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    4
    Trophy Points:
    18
    If you are forced to have an http:// in front of everything then the rule was entered before that problem was fixed.

    You can tell also that this was an "old" rule if there are special characters that are URI encoded and/or it is not surrounded by double quotes.
     
  3. wolfy

    wolfy Well-Known Member

    Joined:
    Jul 20, 2005
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Canada
    these were new rules entered today.

    when entering the "redirect to" string, cpanel java script insists I use http://whatever.... when the request is complete, it says everything was fine, untill i try to visit the redirected area, and when i go back to the redirect control area and view my current and newly addad redirects, all new redirects have http://http:// at the beginning. old redirects remain unchanged and working fine.
     
  4. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    4
    Trophy Points:
    18
    Sounds like theme was updated but the tree was not, can you submit a ticket 'ATTN Dan' referencing this forum thread so i can verify and resolve the problem?

    thanks!
     
  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    This is resolved in

    RELEASE rev 24654
     
Loading...

Share This Page